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1 Формирование электрических схем 
 
1.1 Краткие сведения из теории 
 
Цель занятия - получить практические навыки работы с графическими 

средствами для автоматизированного формирования электрических схем. 
В соответствии с ГОСТ 2.701-84 к основным конструкторским докумен-

там относятся электрические схемы, на которых в виде условных изображений 
или обозначений показываются составные части изделия и связи между ними. 

Электрическая структурная схема определяет основные функциональ-
ные части изделия (элементы, устройства, функциональные группы), их назна-
чение и связи. Функциональная схема - служит для разъяснения определенных 
процессов, протекающих в отдельных функциональных цепях изделия или в 
изделии в целом, на ней обычно не указываются элементы и связи, не влияю-
щие на принципы функционирования устройства: соединители, цепи коррек-
ции, питания и т.д. Эти схемы используются при изучении принципов работы 
изделий, при их наладке, контроле и ремонте. 

Принципиальная схема определяет полный состав элементов и связи 
между ними и, как правило, дает детальное представление о принципах работы 
изделия. Она служит основанием для разработки других конструкторских до-
кументов, в том числе, чертежей конструктивов. Принципиальная схема ис-
пользуется также при наладке, контроле и ремонте устройства. На ней изобра-
жаются все электрические элементы и устройства, необходимые для осуществ-
ления  контроля  в изделии заданных электрических процессов, все электриче-
ские связи между ними, а также элементы (соединители, зажимы и т.п.), кото-
рыми заканчиваются входные и выходные цепи. 

Общие требования к выполнению схем вручную и автоматизированным 
способом регламентируются ГОСТ 2.301-68 и ГОСТ 2.004-79.  ГОСТ 2.702-75 
определяет правила выполнения электрических схем изделий всех отраслей 
промышленности и энергетических сооружений. ГОСТ 2.743-91 и 2.759-82 оп-
ределяют соответственно условные графические обозначения (УГО) элементов 
цифровой и аналоговой техники.  

Формирование электрических схем радиоэлектронных устройств (РЭУ) 
выполняется в интерактивном режиме в среде специальных графических редак-
торов, ориентированных на решение этой задачи. Примером схемного редакто-
ра является программа OrCAD Capture [1]. Кроме того, OrCAD Capture служит 
управляющей оболочкой, из которой можно запускать другие программы сис-
темы OrCAD. Он позволяет выполнять в интерактивном режиме значительную 
часть проектных процедур структурного синтеза на функциональном и схемо-
техническом иерархических уровнях. Сформированные схемы можно вывести 
на графопостроитель или принтер для получения конструкторской документа-
ции. Графический редактор OrCAD Capture предназначен для создания и редак-
тирования электрических схем и библиотек схемных элементов.  
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Библиотеки схемных элементов содержат информацию о геометрической 
форме, размерах УГО элементов электронных схем, а также дополнительную 
информацию об имени, номерах и типе каждого их вывода. Информация о 
схемных элементах хранится в библиотечных файлах *.olb. 

Библиотеки (файлы *.olb) программы OrCAD Capture содержат более 30 
тысяч элементов. Однако не все из них имеют УГО, соответствующие отечест-
венным стандартам. Поэтому часто возникает необходимость редактировать 
УГО элементов и лишь иногда - пополнять библиотеки новыми элементами. 

В среде OrCAD Capture возможно создавать символы компонентов и за-
тем помещать их в существующие или новые библиотеки. Для создания нового 
символа создается новая или открывается существующая библиотека и затем 
выбирается команда Design>New>Part. Для редактирования символа компо-
нента открывается существующая библиотека по команде File>Open>Library. 
После нажатия на значок «+» на строке с именем библиотеки выводится ее ка-
талог. Приступить к редактированию выбранного элемента можно двойным 
щелчком курсора.  

Чтобы привести элемент библиотеки в соответствие требованиям отече-
ственных стандартов, достаточно выполнить редактирование их УГО, сохраняя 
при этом информацию о структуре и компоновке элемента. В работе рассмат-
ривается задача редактирования элементов библиотеки 7400.olb. В этой биб-
лиотеке приведены интегральные схемы (ИС) серии SN74, полным аналогом 
которых являются ИС серии К155 отечественного производства. Соответствие 
некоторых ИС серий SN74 и К155 приведено в таблице 1.1 
 

Таблица 1.1 
Серия SN74 Серия К155 Функция 

7400           К155ЛА3 ЧЕТЫРЕ "2И-НЕ" 
7401 К155ЛА8 ЧЕТЫРЕ "2И-НЕ" О.К.      
7402 К155ЛЕ1 ЧЕТЫРЕ "2ИЛИ-НЕ" 
7403 K155ЛА9 ЧЕТЫРЕ "2И-НЕ" О.К. 
7404 К155ЛН1 ШЕСТЬ ИНВЕРТОРОВ 
7405 К155ЛН2 ШЕСТЬ ИНВЕРТОРОВ С О.К.
7406 K155ЛН3 ШЕСТЬ ИНВЕРТОРОВ С О.К.
7408 К155ЛИ1 ЧЕТЫРЕ "2И" 
7410 К155ЛА4 ТРИ "3И-НЕ" 
7412 K155ЛА10 ТРИ "3И-НЕ" С О.К. 
7420 K155ЛА1 ДВА "4И-НЕ" 
7422 К155ЛА7 ДВА "4И-НЕ" С О.К. 
7425 K155ЛЕ3 ДВА "4ИЛИ-НЕ"   СТРОБ.  
7427 К155ЛЕ4 ТРИ "3ИЛИ-НЕ" 
7430 K155ЛА2 ОДИН "8И-НЕ" 
7432 К155ЛЛ1 ЧЕТЫРЕ "2ИЛИ" 
7472 K155ТВ1 ТРИГГЕР "J-K" 
7474 K155ТМ2 ДВА  D-ТРИГГЕРА 
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В верхней части окна OrCAD Capture находится выпадающее меню, а не-
много ниже — панель инструментов, на которой размещены кнопки команд. 
Проектирование новой схемы начинается с создания нового проекта. Для этого 
надо выполнить команду File>New>Project или щелкнуть на кнопке Create 
document, расположенной на панели инструментов. На экране появится диало-
говая панель New Project, в которой надо задать имя проекта (верхнее поле), 
например PR1, выбрать тип проекта и определить, где он будет располагаться 
на жестком диске (нижнее поле). Можно указать для проекта несуществующую 
папку — OrCAD Capture создаст ее автоматически.  

В OrCAD определены четыре типа проектов — это видно на диалоговой 
панели New Project. Выберем проект типа Analog or Mixed-Signal Wizard. Этот 
тип проекта рекомендуется для решения основных задач курса, когда сформи-
рованные схемы необходимо моделировать на функциональном и схемотехни-
ческом уровнях с помощью программы Pspice A/D. 

В начале создания проекта предусмотрена загрузка прототипа при выборе 
в диалоговом окне опции Create based upon an existing project. Рекомендуется 
выбрать опцию Create a blank project, при этом создается стандартный проект 
простой структуры, допускающий возможность моделирования схемы с помо-
щью программы Pspice A/D. 

После нажатия кнопки «OK» загружается менеджер проекта с заданным 
именем (PR1). Проект имеет папки Design Resources, Outputs и PSpice 
Resources. Папка Design Resources содержит проект схемы PR1.dsn и папку 
библиотек схемных элементов Library. Чтобы открыть проект схемы необходи-
мо щелкнуть по значку “+”. Он содержит папку SCHEMATIC1, в которой нахо-
дится страница схемы: PAGE1. Эти имена легко изменить в менеджере проекта, 
щелкнув правой кнопкой мыши на неугодном имени и указав в открывшемся 
контекстном меню команду Rename. Проект схемы также содержит папку 
Design Cache (кэш проекта).  

Чтобы открыть страницу схемы необходимо дважды по ней щелкнуть. 
При этом в окне OrCAD Capture в левой части будет расположен менеджер 
проекта, а правую часть занимать окно схемы. Обратите внимание: содержимое 
меню команд зависит от того, какое из названных окон активно. 

Активизируя окно схемы,  переведем редактор в режим формирования 
схемы. При этом появится палитра инструментов Tool Palette, с помощью кото-
рой проектируется схема. По умолчанию панель Tool Palette располагается вер-
тикально в правой части экрана и дублирует команды меню Place. Наиболее 
часто используемые кнопки расположены в верхней части панели. Для выпол-
нения работы достаточно использовать кнопки: 

- Select - для переключения курсора мыши в режим выбора (выделения) 
объектов схемы (элементов, цепей, имен и т. п.); 

- Place Part - позволяет размещать элементы схемы; 
- Place wire - для соединения элементов проводниками (цепями); 
- Place junction - для электрического соединения пересекающихся про-

водников (цепей); 
- Place Gnd - для размещения «земли»; 
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- Place Power - для размещения элементов питания; 
- Place net alias – для ввода имен проводников (цепей).  
Для более сложных схем, в том числе имеющих иерархическую структу-

ру, необходимо дополнительно использовать кнопки: 
- Place bus - для размещения линий групповой связи (шин); 
- Place bus entry - для соединения проводников  с «жилами» шины; 
- Place hierarchical block -для размещения иерархических блоков; 
- Place pin - для размещения выводов иерархического блока; 
- Place no connect - для отметки незадействованных выводов элементов. 
Формирование схемы рекомендуется выполнять в следующей последова-

тельности: 
- разместить элементы (Place Part и Place Gnd, Place Power); 
- соединить их выводы между собой (Place wire); 
- при необходимости задать имена цепей (Place net alias). 
Щелкнем на пиктограмме Place Part (разместить элемент). Появится диа-

логовая панель с одноименным названием, на которой видны имена подклю-
ченных к проекту библиотек (левое нижнее окно) и список имеющихся в них 
элементов. Справа находится кнопка Add Library, нажатие которой позволяет 
добавить выбранную библиотеку. Для выполнения задания рекомендуется ис-
пользовать библиотеки из папки ..Capture\Library\PSpice: 

- analog.olb – базовая библиотека аналоговых элементов; 
- sourse.olb – библиотека источников сигналов; 
- sourcstm.olb –библиотека источников сигналов Stimulus Editor; 
- 7400 – библиотека ИС серии SN74; 
- bipolar.olb – библиотека биполярных транзисторов. 
Щелкните на любом имени элемента, и его условное графическое изо-

бражение (УГО) появится в правом нижнем окне. О функции элемента можно 
судить по его имени или УГО.  

Выделим компонент R (резистор) из библиотеки analog.olb. Нажмем 
кнопку OK и укажем в окне схемы желаемое место. Чтобы зафиксировать по-
ложение элемента, щелкнем левой кнопкой мыши. Обратите внимание: рядом с 
УГО появилось имя R1 — это позиционное обозначение компонента. Перемес-
тим курсор в другое место и опять нажмем левую кнопку. На экране появится 
еще один такой же элемент с именем R2. Таким образом, можно размещать 
сколько угодно копий, пока Вы не нажмете клавишу [Esc] или правую кнопку 
мыши, исполнив затем команду End Mode в открывшемся контекстном меню. 
Есть еще один способ снять активность текущей команды — переместить кур-
сор мыши на пиктограмму Select и щелкнуть левой кнопкой. 

Чтобы удалить ненужный элемент подведем курсор к нему и выделим его 
щелчком мыши. Выделенный элемент помечается красным цветом. Нажмем 
клавишу Del, и элемент исчезнет с экрана. Как размещаемые, так и уже разме-
щенные можно вращать и зеркально отображать. Для этого нажатием правой 
кнопки мыши активизируется панель с командами Rotate, Mirror Vertically, 
Mirror Horizottally.  
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Размещенные резисторы имеют одинаковые значения параметра Value = 
1K (сопротивление 1 кОм). Чтобы изменить значения этого параметра, необхо-
димо дважды щелкнуть по нему.    

Аналогичным образом выполняется размещение всех элементов схемы. 
УГО общей точки схемы («земли») размещаются аналогично командой Place 
Ground – необходимо использовать элемент «0» из библиотеки sourse.olb, УГО 
питания схемы – командой Place Power (элемент VCC из библиотеки Capsym). 
Чтобы получить законченную схему, размещенные элементы необходимо со-
единить проводниками. Для этого надо щелкнуть на пиктограмме Place wire 
(разместить проводник). Обратите внимание: курсор мыши изменил свою фор-
му, теперь он похож на небольшое перекрестие. Выполним все необходимые 
соединения, нажимая левую кнопку мыши для обозначения начала и конца ка-
ждого проводника.  

Чтобы нарисовать сложную цепь, неоднократно меняющую направление, 
необходимо в точках излома фиксировать уже нарисованную часть проводника 
щелчком левой кнопки мыши. Чтобы закончить рисование цепи, надо нажать 
правую кнопку мыши, а затем исполнить команду End Wire либо произвести 
двойной щелчок в точке, где заканчивается проводник. При постоянно нажатой 
кнопке мыши рисование цепи прекращается, если кнопку отпустить при дости-
жении вывода элемента. При этом активность команды не снимается. Чтобы 
закончить процесс рисования проводников надо нажать клавишу [Esc] или 
щелкнуть на пиктограмме Select (или выбрать новую команду). 

Линии связи и выводы элементов схемы допускается соединять между 
собой только встык, без наложения. Визуальный контроль подключения цепи к 
контакту весьма прост: свободный вывод компонента заканчивается неболь-
шим квадратиком, который исчезает, если произошло соединение. И наоборот, 
если проводник подключается к другой цепи, то в точке их соприкосновения 
появляется так называемое Junction-соединение (довольно жирная точка мали-
нового цвета). Добавим, что если проводники соприкасаются своими концами, 
то создаваемый электрический контакт не порождает Junction-соединения. 

Заканчивая проектирование схемы, можно назначить имена входным, вы-
ходным и другим цепям. Щелкнем на пиктограмме Place net alias - откроется 
панель Place Net Alias, используемая для задания имени цепи. Введем с клавиа-
туры имя, например In, и нажмем кнопку OK. Теперь надо указать, для какой 
цепи это имя предназначено. По этой причине габаритный прямоугольник, 
привязанный к курсору мыши и показывающий размеры имени, необходимо 
«прижать» непосредственно к той цепи, которую мы именуем.  

Эту операцию необходимо проделать для всех шин и их ответвлений. 
Другие цепи можно не именовать. В этом случае они получат системные имена, 
которые им присвоил графический редактор (неудобные для визуального вос-
приятия). Поэтому рекомендуется именовать также цепи, сигналы которых 
представляют интерес при моделировании схемы. 

Проверка правильности схемы выполняется по команде Tools>Design 
Rules Check (DRC), при этом формируется отчет (файл с расширением .drc), в 
который помешаются сообщения о всех обнаруженных ошибках и нарушениях.  
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1.2 Описание последовательности выполнения задания 
 
1.2.1 Редактирование УГО компонента  
 
Определить аналог заданной ИС из состава серии SN74. 
Открыть библиотеку 7400.olb командой File>Open>Library. 
Открыть окно редактирования символа выбранного компонента. 
Удалить существующие элементы изображения УГО командой 

Edit>Delete. При этом штрих-пунктирный прямоугольник будет ограничивать 
габариты УГО символа. Размеры этого прямоугольника при необходимости 
можно изменить «буксировкой» его углов. Выводы компонента будут разме-
щены вне этого прямоугольника, соприкасаясь с ним. 

Сформировать новое изображение УГО командой Place из следующих 
элементов: Rectangle (прямоугольник), Line (линия), Ellipce (эллипс, окруж-
ность), Arc (дуга), Text (текст), IЕЕЕ Symbols (специальные символы). 

Отечественные стандарты допускают упрощенное изображение цепей пи-
тания интегральных схем, при этом выводы питания и «земли» удобно сделать 
невидимыми (нулевой длины). Для этого двойным щелчком следует выделить 
редактируемый вывод и в открывшейся панели изменить значение параметра 
Shape на Zero Length.  

Выполнить редактирование свойств компонента командой Options> 
Package Properties. В диалоговом окне этой команды содержатся следующие 
данные:  

- Name — имя символа;  
- Part Reference Prefix — префикс позиционного обозначения (следует 

привести в соответствие отечественным стандартам, например, R - для резисто-
ра, С - для конденсатора, DA - для аналоговой ИС, DD - для цифровой ИС и 
т.п.);  

- РСВ Footprint — тип корпуса компонента;  
- Create Convert View — необходимость создания преобразованного изо-

бражения символа;  
- Parts per Package — общее количество секций в корпусе компонента;  
- Homogeneouse или Heterogeneouse — выбор между компонентами с сек-

циями одинакового или разного типа;  
- Alphabetic или Numeric — выбор между обозначениями секций много-

секционных компонентов буквами латинского алфавита, например DD1A, 
DD1B, DD1C и т.д. или цифрами, например DD1-1, DD1-2, DD1-3 (следует вы-
брать второй вариант);  

- Part Aliases — определение псевдонимов символов (например, компо-
ненту 7400 можно присвоить псевдоним LA3 или K155LA3);  

- Attach Implementation — подключение модели PSpice;  
- Pin Numbers Visible — отображение на схеме номеров выводов.  
Выполнить просмотр изображений всех секций многосекционного ком-

понента по команде View>Package, при необходимости перейти к редактиро-
ванию отдельной секции щелчком курсора. 
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Представить полученные результаты преподавателю на проверку. 
Закрыть окно редактирования, подтвердив сохранение внесенных изме-

нений Save changes to Part. 
Закрыть библиотеку 7400.olb, подтвердив сохранение внесенных измене-

нийt. 
  
1.2.2 Формирование схемных решений  
 
Создать новый проект командой File\New\Project. 
Открыть страницу Page 1. 
Установить требуемые для работы параметры страницы командой 

Options\Design Template (закладка Page Size). 
Разместить на странице элементы схемы командой Place\Part. 
При необходимости разместить на странице элементы «земли» и питания 

командами Place Ground, Place Power. 
Соединить проводниками выводы элементов командой Place wire. 
При необходимости выполнить редактирование позиционных обозначе-

ний и параметров схемных элементов. 
Назначить имена входным и выходным цепям командой Place net alias. 
Записать сформированный проект командой File>Save; 
Выполнить проверку правил выполнения схем командой Tools>Design 

Rules Check. Если были выявлены грубые ошибки, устранить их и повторно 
выполнить проверку. 

Представить полученные результаты преподавателю на проверку. 
Закрыть окно редактирования, подтвердив сохранение внесенных изме-

нений. 
 
1.3 Контрольные вопросы 
 
1.3.1 Какие функции выполняет редактор схем при автоматизированном 

проектировании электронных устройств? 
1.3.2 Для каких целей используются библиотеки схемных элементов? 
1.3.3 Какая информация о схемных элементах заносится в библиотеку? 
1.3.4 Перечислите основные типы электрических схем, назовите их на-

значение и основные правила построения. 
1.3.5 Из каких основных элементов формируется изображение схемы? 
1.3.6 Перечислите основные команды OrCAD Capture и поясните их на-

значение.  
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2 Функциональное проектирование аналоговых РЭУ 
 
2.1 Краткие сведения из теории 

 
Цель работы - получить практические навыки проектирования аналого-

вых РЭУ на этапе функционального проектирования. 
При проектировании аналоговых РЭУ на функциональном иерархиче-

ском уровне разрабатываются структурные или функциональные схемы, базо-
выми элементами которых являются типовые функциональные звенья и узлы.  

На рисунке 2.1 приведена структурная схема датчика пламени. Датчики 
пламени предназначены для работы в составе системы защитной автоматики 
газовых теплогенераторов. Они должны вырабатывать сигнал аварийного от-
ключения подачи газа при пропадании факела газовой горелки. Интенсивность 
светового потока от газового факела изменяется во времени. Частотный спектр 
полезного сигнала, вырабатываемого фотоприемником, лежит в диапазоне 4 - 8 
Гц. Кроме полезного сигнала на датчик пламени воздействуют помехи в виде 
естественного освещения (0 – 0.1 Гц) и искусственного освещения (100 Гц и 
высшие гармоники).  

Схема датчика пламени (рисунок 2.1) содержит: 
- фотодатчик (ФД); 
- частотно-избирательный усилитель (У); 
- амплитудный детектор (Д); 
- пороговый элемент (ПЭ).  

 
 

 
 
 
 
 

Рисунок 2.1 - Структурная схема датчика пламени  
 
Основными требованиями, предъявляемыми к датчикам пламени, явля-

ются надежность срабатывания (в основном определяется избирательностью 
усилителя) и время срабатывания (определяется длительностью переходных 
процессов в узлах схемы). Требуется обеспечить  значение коэффициента пере-
дачи усилителя в полосе пропускания на уровне 70 дБ, а в полосе задерживания 
– не более 0 дБ. Неравномерность коэффициента усиления в полосе пропуска-
ния не должна превышать 3 дБ. Время срабатывания датчика пламени при про-
падании газового факела не должно превышать 0.4 с. 

В ходе выполнения задания необходимо по исходным данным рассчитать 
параметры элементов схемы, а в случае необходимости скорректировать ее 
структуру. Результаты синтеза необходимо контролировать выполнением рас-
четов амплитудно-частотной характеристики (АЧХ) частотно-избирательного 
усилителя, а также расчетов реакции датчика пламени во временной области на 
появление и пропадание полезного сигнала. 

   

    ФД 

 
    У 

 
     Д 

 
    ПЭ 
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2.2 Порядок выполнения работы 
 
2.2.1 Для построения схемы частотно-избирательного усилителя исполь-

зуем подход трансформации описания. В качестве исходного описания необхо-
дима математическая модель объекта, допускающая ее разложение на модели 
базовых элементов. Такую модель будем искать в виде передаточной функции в 
операторной форме. Исходные данные для построения передаточной функции 
частотно-избирательного усилителя задаются параметрами графика допусков 
АЧХ (рисунок 2.2).  
 

                                                 H                              ∆H 
                                                 Hо                          
              
  
        
                                                 Hз 
 
                                                     0    fзн   fпн    fпв   fзв      f 

Рисунок 2.2 
 

Решите задачу аппроксимации АЧХ частотно-избирательного усилителя  
с помощью программы Appr. Если частотно-избирательный усилитель предпо-
лагается построить на избирательных усилительных каскадах, то в этом случае 
его частотная характеристика должна быть симметричной: 
 

                     fзн,⋅ fзв   =   fпн ⋅ fпв ,               (2.1) 
 

а передаточная функция будет иметь вид:  
 

       n/2              (ωi /Qi)s 
                       H(s) =  П K0i ———————— ,                                             (2.2) 
                                   i=1      s2 + (ωi/Qi)s + ωi

2 

 
где  n  - порядок передаточной функции;   
       ωi - частота полюса; 
       Qi - добротность полюса.  

Программа запрашивает у пользователя исходные данные:  
- тип фильтра (полосно-пропускающий); 
- значения граничных частот полосы задерживания fзн, fзв и пропускания    

fпн , fпв; 
- вид аппроксимации (Баттерворта или Чебышева); 
- неравномерность АЧХ в полосе пропускания ∆H;  
- затухание АЧХ на границах полосы задерживания (Hо – Hз). 
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Если условие (2.1) не выполняется, то программа предложит выполнить 
расчет для более жестких условий работоспособности с расширением полосы 
пропускания или задерживания. После завершения расчетов записать в отчет 
результаты: n, ωi/Qi , ω i2. Задаться значениями K0i . 

Частотно-избирательный усилитель также можно построить из каскадов, 
ослабляющих верхние частоты, и каскадов, ослабляющих нижние частоты. У 
первой группы каскадов передаточная функция имеет в общем случае вид:   

 
     s      (n+1)/2         s2 

                             H(s) = ———   П   ———————                                      (2.3) 
                                          s + ω1   i=2  s2 + (ωi/Qi)s + ωi

2 

 
а у второй группы каскадов передаточная функция имеет в общем случае вид:   
 

   ω1     (n+1)/2         ωi
2 

                             H(s) = ———   П   ———————                                       (2.4) 
                                          s + ω1   i=2  s2 + (ωi/Qi)s + ωi

2 

 
В этом случае задачу аппроксимации необходимо искать отдельно для 

передаточных функций вида (2.3) и (2.4), задавая соответствующий тип. 
Так как модель частотно-избирательного усилителя получена в виде про-

изведения сомножителей первого и второго порядка, то его можно построить из 
включенных каскадно усилительных звеньев первого и второго порядка. В ка-
честве модели усилительных каскадов с передаточными функциями, входящи-
ми в (2.2), (2.3) и (2.4) в качестве сомножителей, можно использовать элемент 
LAPLACE из библиотеки ABM.olb 

2.2.2 Модель амплитудного детектора можно представить звеном идеа-
лизированного выпрямителя - элемент TABLE и фильтра нижних частот 
(ФНЧ)  - элемент LAPLACE. 

Определите параметры графика допусков АЧХ ФНЧ амплитудного детек-
тора: fп ,  fз . Решите задачу аппроксимации АЧХ ФНЧ с помощью программы 
Appr. Программа запрашивает у пользователя исходные данные:  

- тип фильтра (ФНЧ); 
- значения граничных частот полосы пропускания fп и задерживания fз; 
- вид аппроксимации (Баттерворта или Чебышева); 
- неравномерность АЧХ в полосе пропускания ∆H = 3 дБ;  
- затухание АЧХ в полосе задерживания  (Hо – Hз) = 20 дБ. 

В ходе решения задачи аппроксимации определяют передаточную функцию 
фильтра в операторной форме в виде (2.4). Запишите в отчет результаты: n, 
ωi/Qi , ω i2 .  

2.2.3 Для формирования функциональной схемы создайте проект 
\CAD\LR2\lr2 командой File>New>Project.Откройте в менеджере проекта стра-
ницу SCHEMATIC1:PAGE1. 
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Сформируйте функциональную схему датчика пламени, используя эле-
менты звеньев LAPLACE и TABLE из библиотеки abm.olb.  

Параметры NUM и DENOM определяют числители и знаменатели пере-
даточных функций элементов LAPLACE. Например, для звена второго порядка, 
имеющего передаточную функцию H(s) = 10·63s/(s2+63s+3400),параметры 
NUM=10*63*s, DENOM= s*s+63*s+3400. 

Параметры ROW1 – ROW5 элементов TABLE определяют координаты 
характерных точек статической передаточной характеристики. Для двухполу-
периодного амплитудного детектора можно использовать аппроксимацию пе-
редаточной характеристики, представленную на рисунке 2.3. Аналогично мож-
но задать модель порогового элемента. 

 

 
Рисунок 2.3 

 
В программе OrCAD Pspice AD модель появляющегося и пропадающего 

сигнала от фотодатчика можно получить путем перемножения мгновенных 
значений э.д.с. двух источников напряжения – гармонического (SIN) и им-
пульсного (PULSE). Эквивалентная схема модели входного сигнала представ-
лена на рисунке 2.4. Источник V3 имитирует помеху частотой 100 Гц. В схеме 
использованы сумматор SUM и умножитель MULT из библиотеки abm.olb.  

 

 
Рисунок 2.4 
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Чтобы получить требуемые параметры входного сигнала, необходимо за-
дать параметры источников напряжения.  Параметры модели импульсного сиг-
нала представлены в таблице 2.1.  

 
Таблица 2.1 - Параметры импульсного сигнала  
Обозначе-

ние 
Параметр  

 
Размер-
ность 

V1  Начальное значение  В 
V2  Максимальное значение  В 
TD  Задержка переднего фронта  с 
TR  Длительность переднего фронта с 
TF  Длительность заднего фронта  с 
PW  Длительность импульса  с 
PER   Период повторения  с 

 
Параметры модели гармонического сигнала представлены в таблице 2.2.  
 

Таблица 2.2 - Параметры гармонического сигнала  
Обозначе-

ние 
Параметр Размер-

ность 
VOFF  Постоянная составляющая  В  

VAMPL  Амплитуда  В 
FREQ  Частота  Гц 

TD  Задержка  с 
DF  Коэффициент затухания  1/с 

PHASE  Фаза  град. 
 

 
2.2.4 Создайте профиль моделирования командой PSpice>New Simulation 

Profile для расчета частотной характеристики усилителя, для этого на закладке 
Analysis: 

- установите вид анализа (Analysis type) – AC Sweep/Noise; 
- задайте закон изменения AC Sweep Type: Linear и пределы изменения 

частоты (Start Frequency = <fзн>, End Frequency = <fзв >, Total Points = 100); 
- закройте окно редактирования нажатием кнопки OK. 
Выполните моделирование  командой PSpice>Run. При этом выполняет-

ся запуск программы PSpice A/D. 
Выведите на экран график АЧХ, для этого командой Trace>Add Trace 

откройте окно Add Trace и в окне Trace Expression задайте значение 
DB(V(OutA)/V(In)), подтвердите выбор нажатием клавиши ОК (OutA – имя вы-
ходного узла усилителя, In - имя входного узла усилителя). 
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Определите затухание АЧХ (Hо – Hз) на границах полосы задерживания,  
коэффициент усиления и его неравномерность в полосе пропускания. 

Оцените соответствие формы и основных параметров АЧХ заданным 
требованиям, при наличии существенных отклонений определите причины и 
устраните их, повторите расчет АЧХ. Зарисуйте график АЧХ. Удалите график 
командой Trace>Delete All Traces. 

2.2.5 Для анализа реакции на появление и пропадание факела активируйте 
окно программы OrCAD Capture. Выполните редактирование профиля модели-
рования командой PSpice>Edit Simulation Profile для расчета во временной 
области, для этого на закладке Analysis: 

- задайте вид анализа (Analysis type) – Time Domain (Transient); 
- задайте значение интервала расчета Run to Time = 1s; 
- закройте окно редактирования нажатием кнопки OK. 
Выполните моделирование во временной области командой PSpice>Run. 

Выведите на экран графики сигналов V(In), V(OutA), V(OutD), V(Out). Для это-
го командой Trace>Add Trace откройте окно Add Trace и выберите эти сигна-
лы, подтвердите выбор нажатием клавиши ОК (In - имя входного узла усилите-
ля, OutA – имя выходного узла усилителя, OutD - имя выходного узла детекто-
ра, Out - имя выходного узла устройства). 

Оцените задержку реакции устройства на пропадание сигнала пламени и 
сравните с требованиями задания. В случае необходимости скорректируйте 
значения параметров элементов датчика пламени, повторите расчеты АЧХ и 
переходных процессов. Зарисуйте графики. Представьте результаты преподава-
телю.  

2.3 Оформление  отчета 
  

Отчет должен содержать: 
- исходные данные (условия работоспособности); 
- функциональную схему датчика пламени; 
- результаты расчета параметров элементов схемы; 
- результаты анализа (график АЧХ усилителя, временные диаграммы сиг-

налов, значения выходных параметров); 
- выводы. 
 

2.4 Контрольные вопросы 
 

2.4.1 К какому этапу проектирования относится выполненная работа? 
2.4.2 Перечислите выполненные проектные процедуры. 
2.4.3 Какие типовые подходы были использованы к выполнению каждой 

проектной процедуры? 
2.4.4 Каким образом можно оценить корректность разработанной схемы?  
2.4.5 Каким образом в использованной модели учитывается влияние по-

мех? 
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3 Формирование схемных решений  
 
3.1 Краткие сведения из теории 

 
Цель работы - получить практические навыки формирования схемных 

решений для аналоговых РЭУ на этапе схемотехнического проектирования. 
При проектировании аналоговых РЭУ на схемотехническом иерархиче-

ском уровне разрабатываются функциональные и принципиальные схемы, ба-
зовыми элементами которых являются электрорадиоэлементы (ЭРЭ). Маршрут 
схемотехнического  проектирования  начинается  с уточнения  технического  
задания  и синтеза варианта структуры (схемного решения).  

На современном этапе формализация этой задачи в большинстве случаев 
сталкивается  со значительными  трудностями, поэтому ее решение в значи-
тельной степени возлагается на человека. В современных подсистемах автома-
тизации схемотехнического проектирования используются подходы, основан-
ные на переборе законченных структур и выделении варианта из обобщенной 
структуры. В качестве обобщенной структуры можно рассматривать банк типо-
вых схемных решений (БСР). В состав БСР могут входить принципиальные или 
функциональные электрические схемы РЭУ, а также схемные решения для ти-
повых функциональных звеньев и узлов (подсхем), известные администратору 
БСР. В этом случае инженер-схемотехник, опираясь на свои знания и интуи-
цию, проводит синтез схемы в режиме  диалога с ЭВМ путем поиска или пере-
бора вариантов решений из тех, которые хранятся в БСР. 

Если исходное описание проектируемого  устройства представлено в виде 
структурной схемы, полученной  на  этапе  функционального  проектирования, 
то в этом случае разработчик может построить функциональную схему РЭУ 
путем поиска в БСР функциональных подсхем для каждого элемента структур-
ной схемы. При соединении отдельных подсхем между собой в соответствии с 
исходной структурной схемой следует учитывать вопросы согласования уров-
ней сигналов, нагрузочной способности и т.д. Таким образом, реализуется ти-
повой подход выделения варианта схемного решения для звена из обобщенной 
структуры – БСР. 

Применение в процессе  автоматизированного  схемотехнического проек-
тирования БСР значительно расширяет информационные возможности  разра-
ботчика, концентрирует его внимание на лучших схемных решениях, известных 
в мировой практике. При  этом  удается  повысить качество проектных реше-
ний, значительно сократить сроки проектирования, а также снизить требования 
к квалификации разработчика РЭУ в области схемотехники. 

В  ходе выполнения лабораторной работы может быть использован БСР 
для частотно-избирательных фильтров, который реализован в  виде  иерархиче-
ски  структурированного набора данных, выполненного в среде схемного гра-
фического редактора Capture. Схема верхнего уровня Filters.dsn служит класси-
фикационной схемой частотно-избирательных фильтров. Ее элементы указы-
вают на готовые схемные решения для активных RC-фильтров первого-второго 
порядка. 
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Для найденных подсхем, как правило, необходимо решать задачу расчета 
параметров элементов для обеспечения требуемых значений выходных пара-
метров. Могут использоваться аналитический или численный подходы. В дан-
ной работе можно ограничиться аналитическими расчетами по инженерным 
методикам. 

Корректность полученных проектных решений необходимо проверить 
выполнением процедуры анализа с помощью программы PSPICE.  

 
3.2 Порядок выполнения работы 
 
3.2.1 Структурный и параметрический синтез  
 
Создать проект \CAD\LR4\lr4 командой File>New>Project. Открыть в ме-

неджере проекта страницу SCHEMATIC1:PAGE1. 
Открыть проект \CAD\BSR\filters.opj командой File>Open>Project. От-

крыть в менеджере проекта страницу схемы верхнего уровня Filter:PAGE1. По 
ключевым признакам найти в классификационной схеме БСР элементы, указы-
вающие на необходимые подсхемы.  

Сформировать функциональную схему фильтра высокого порядка, ис-
пользуя подсхемы звеньев первого или второго порядка из БСР.  

Выделить найденный элемент правой кнопкой мыши, затем нажать левую 
кнопку мыши и выполнить команду Descend Hierarchy.  В открывшейся стра-
нице БСР выделить подсхему и скопировать в буфер обмена (Edit>Copy). За-
крыть страницу подсхемы. Активировать рабочую страницу создаваемой схемы 
и скопировать на нее подсхему из буфера обмена (Edit>Paste). 

Выполнить редактирование позиционных обозначений элементов схемы. 
Рассчитать значения параметров элементов схемы. Для этого с командной 

строки запустить на выполнение программу NE.exe с параметром <имя>.txt 
(указывается через пробел). В окне редактора NE.exe задать требуемые значе-
ния выходных параметров. Нажать левый Shift и клавишей ↓ выделить текст с 
расчетными формулами. Нажать клавишу F9, а затем два раза клавишу F5. За-
писать в отчет рассчитанные значения параметров элементов. Подставить рас-
считанные значения в поле Value элементов схемы. 

Сохранить схему в наборе данных на жестком диске. 
 

3.2.2 Анализ  частотных характеристик  
 
Создать профиль моделирования командой PSpice>New Simulation 

Profile для расчета частотной характеристики фильтра 
Выполнить моделирование командой PSpice>Run.  
Вывести на экран график АЧХ. Определить затухание АЧХ (Hо – Hз) на 

границах полосы задерживания,  коэффициент усиления и его неравномерность 
в полосе пропускания. 
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Оценить соответствие формы и основных параметров АЧХ заданным 
требованиям, при наличии существенных отклонений определить причины и 
устранить их, повторить расчет АЧХ. Зарисовать график АЧХ. Удалить график 
командой Trace>Delete All Traces. 

 
3.3 Оформление  отчета 
 
Отчет должен содержать: 
- исходные данные; 
- функциональную схему фильтра; 
- результаты расчета параметров элементов схемы; 
- результаты анализа (график АЧХ); 
- выводы. 
 
3.4 Контрольные вопросы 
 
3.4.1 К какому этапу проектирования относится выполненная работа? 
3.4.2 Перечислите выполненные проектные процедуры. 
3.4.3 Какие типовые подходы были использованы к выполнению каждой 

проектной процедуры? 
3.4.4 Каким образом можно оценить корректность разработанной схемы?  
3.4.5 Какие режимы проектирования использованы при выполнении про-

ектных операций и процедур? 
 
 
 
 
 
 
 
 
 



 20 

4 Параметрическая оптимизация 
 
4.1 Краткие сведения из теории 

 
Цель занятия - получить практические навыки применения методов и 

средств параметрической оптимизации для решения задачи параметрической 
синтеза на этапе схемотехнического проектирования. 

Целью параметрической оптимизации является определение значений па-
раметров элементов (вектор внутренних параметров X), обеспечивающих наи-
лучшее соответствие выходных характеристик устройства Y требованиям ТЗ. 
Среди задач схемотехнического проектирования, которые целесообразно  ре-
шать с привлечением методов оптимизации, можно выделить задачи уточнения 
значений параметров элементов схемы, полученных в результате использова-
ния аналитического подхода (инженерных методик расчета). 

Одной из наиболее сложных операций при решении задачи параметриче-
ской оптимизации является этап математической формулировки задачи, кото-
рая включает в себя выбор критерия оптимальности, определение варьируемых 
параметров и задание ограничений.  

Параметрическая оптимизация электронных схем в определенном смысле 
эквивалентна настройке схемы при ее натурном макетировании. Можно выде-
лить следующие этапы оптимизации, соответствующие этапам настройки: 

- описание оптимизируемых характеристик устройства и  критериев оп-
тимальности (выбор настраиваемых характеристик и определение требований к 
ним); 

- выбор варьируемых параметров элементов схемы (определение регули-
руемых элементов схемы); 

- выбор методов оптимизации и их параметров (определение последова-
тельности и плана настройки); 

- выполнение процедуры оптимизации (собственно настройка схемы); 
- анализ результатов, принятие решения о продолжении или прекращении 

поиска, корректировка задания на оптимизацию (оценка соответствия характе-
ристик настраиваемой схемы требованиям ТЗ и принятие решения). 

Для формализации задачи вводится критерий оценки качества каждого из 
вариантов - целевая функция F(X),  выбираются варьируемые параметры X, а 
задача параметрической оптимизации формулируется в виде задачи математи-
ческого программирования   
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Функциональные ограничения в виде неравенств H(X) ≥ 0 и равенств 

G(X)=0 обычно представляют собой условия работоспособности для выходных 
параметров, не участвующих в формировании целевой функции. Прямые огра-
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ничения A≤X≤B могут вытекать из условий физической реализуемости, на-
пример, для резисторов и конденсаторов это допустимые диапазоны значений 
сопротивлений и емкостей. Однако на практике прямые ограничения обычно 
задают более жестко для сокращения размеров области поиска и снижения вы-
числительных затрат.  

Для различных задач могут оказаться предпочтительными определенные 
способы задания целевой функции. Как правило, критерии оптимальности 
формируются таким образом, чтобы в задаче (4.1) требовалось найти минимум 
целевой функции. В задачах, требующих максимального соответствия оптими-
зируемого параметра некоторому желаемому значению, обычно используют 
критерий среднеквадратического отклонения 

 
2* ))(()( yyF −= XX ,                                                       (4.2) 

 
где y* - желаемое значение параметра y.  
Если требуется обеспечить соответствие желаемым значениям несколь-

ких оптимизируемых параметров, то следует воспользоваться взвешенным кри-
терием среднеквадратического отклонения 
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где wi – весовой коэффициент, отражающий важность i-го параметра и 
выполняющий его нормирование. 

При выборе варьируемых параметров необходимо учитывать, что вклю-
чение одного дополнительного элемента приводит к увеличению числа коорди-
нат в пространстве поиска на единицу. Если для пары варьируемых параметров 
xi  и xj при любых их значениях выполняется условие  
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S - чувствительности параметра y к вариациям параметров xi  
и  xj,  появляется бесконечное множество пар значений этих параметров, для 
которых целевая функция не изменяет своего значения. Такая ситуация называ-
ется «овражной». Решение задачи параметрической оптимизации с «овражной» 
целевой функцией сопряжено со значительными трудностями. Поэтому при по-
становке задачи оптимизации следует исключать из вектора варьируемых па-
раметров любой из пары параметров, порождающей «овраг». 

С другой стороны, состав вектора варьируемых параметров должен обес-
печивать достижение поставленной цели оптимизации. То есть, в вектор варьи-
руемых параметров необходимо включать минимально возможное число тех 
параметров, изменение которых обеспечивает такое влияние на значения вы-
ходных параметров, при котором обеспечивается цель оптимизации. Для гра-
мотного выбора варьируемых параметров необходимы знания из области схе-
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мотехники. Прямые ограничения определяют  линейные размеры области поис-
ка по каждой координате. Грамотный выбор прямых ограничений должен обес-
печивать сокращение размеров области поиска при условии, что оптимальное 
решение находится внутри нее.  

Среди локальных алгоритмов оптимизации для целей схемотехнического 
проектирования получили распространение поисковые алгоритмы, использую-
щие информацию о градиенте целевой функции.  

В пакете OrCAD параметрическая оптимизация выполняется методом на-
искорейшего спуска путем взаимодействия модуля PSpice Optimizer с графиче-
ским редактором схем (OrCAD Capture), программой моделирования PSpice и 
постпроцессором Probe.  

При создании схемы с помощью OrCAD Capture список варьируемых па-
раметров задается по команде PSpice>Place Optimizer Parameters .  

Критерий оптимизации задается непосредственно в программе PSpice 
Optimizer, которая вызывается из меню PSpice программы OrCAD Capture по 
команде Run Optimizer.  

В правой верхней части этого окна помещен список значений функций, 
которые могут быть частными критериями или ограничениями (раздел 
Specifications), в нижней — перечень варьируемых параметров (раздел 
Parameters).  

Функции частных критериев или ограничений задаются следующим об-
разом:  

- целевые функции Goal Function программы Probe, записанные в файл с 
расширением имени *.PRB;  

- выражения, заданные в программе PSpice Optimizer.  
Целевые функции программы Probe позволяют рассчитать: 
- минимум MIN(y) или максимум MAX(y) функции y; 
- центральную частоту CenterFreq(ydB,1) по уровню 1 дБ; 
- полосу пропускания BandWidth(ydB,3) по уровню 3 дБ и другие.   
По команде Specifications меню Edit открывается окно co списком спе-

цификации функций. Нажатием кнопки Add открывается меню спецификации 
новой функций. Это же окно открывается щелчком по имени функции из спи-
ска. В окне спецификации вводятся следующие данные:  

- Name — имя функции;  
- Enabled — включение режима расчета функций на следующей итера-

ции;  
- Reference — выбор между внутренней спецификацией (Internal), зада-

ваемой в диалоговом окне, и внешней (External), адресуемой к имени файла 
данных;  

- Weight — весовой коэффициент целевой функции (с их помощью уста-
навливается важность каждой целевой функции и учитываются различия их аб-
солютных значений).  

Внутренняя спецификация задается параметрами:  
- Target — желаемое значение функции;  
- Range — ширина допустимого диапазона значений функции;  
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Constraint — включение/выключение режима учета ограничений. Если 
режим Constraint включен, задаваемая в этом окне функция является ограниче-
нием, в противоположном случае — целевой функцией;  

- Туре — тип-ограничения: =target — равно, >=target — больше или рав-
но, <=target — меньше или равно заданному значению функции.  

Запуск процесса оптимизации выполняется в меню Tune. По команде 
Update Performance рассчитываются характеристики схемы для начальных и 
текущих значений каждого параметра. Это может использоваться для проверки 
корректности постановки задачи оптимизации. Значения целевых функций для 
начальных значений параметров отображаются в главном окне программы, что 
позволяет оценить близость этих значений к оптимальным.  

По команде Update Derivatives вычисляются чувствительности каждой 
целевой функции к изменению каждого параметра, равные частным производ-
ным. Информация о чувствительностях позволяет выбрать параметры, к изме-
нению которых целевые функции наиболее чувствительны. Матрица чувстви-
тельностей отображается на экране по команде Show Derivatives.  

Оптимизация в автоматическом режиме запускается по команде 
Auto>Start. Сначала вычисляется матрица чувствительностей и определяется 
направление изменения параметров. Движение в этом направлении происходит 
до тех пор, пока не перестанет уменьшаться разность между текущим и требуе-
мым значениями оптимизируемых функций. После этого снова вычисляется 
матрица чувствительностей и новое направление изменения параметров. По 
достижении оптимума процесс оптимизации завершается или его нужно оста-
новить по команде Auto>Terminate. Результаты оптимизации отображаются в 
главном окне программы.  

 
4.2 Порядок выполнения 

 
4.2.1 Выполнить  расчет  частотных  характеристик звена при идеальных 

и реальных значениях параметров модели ОУ.  
Определить частные критерии формы АЧХ (команда Trace>Eval Goal 

Function), например:  
- центральную частоту полосы пропускания f0  ( CenterFreq(VdB(Out),1) );  
- ширину полосы пропускания ∆f  ( Bandwidth(VdB(Out),3) );  
- максимум коэффициента передачи (MAX(VdB(Out)) ).  
Сравнить полученные результаты. Оценить отклонения значений частных 

критериев. 
4.2.2 Составить задание на оптимизацию с целью достижения формы 

АЧХ, которую имеет звено с идеальными ОУ. 
4.2.3 Выполнить оптимизацию АЧХ. Оценить полученные значения част-

ных критериев формы АЧХ и критерия оптимальности (RMS Error). 
При неудовлетворительных результатах повторить п.п. 2 – 3 для другого  

набора варьируемых параметров, диапазонов их изменения, другого набора ча-
стных критериев формы АЧХ. 
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4.2.4 Передать найденные параметры элементов в редактор схем (команда 
Edit>UpDate Schematic).Рассчитать АЧХ звена и оценить результаты оптими-
зации. 

 
4.3 Оформление  отчета 
  
Отчет должен содержать: 
- постановку задачи оптимизации, включая: критерий оптимальности, 

варьируемы параметры, ограничения; 
- результаты оптимизации, включая значения параметров элементов и 

АЧХ до выполнения и после оптимизации. 
 

4.4 Контрольные вопросы 
 
4.4.1 К какому этапу проектирования относится выполненная работа? 
4.4.2 Перечислите выполненные проектные процедуры. 
4.4.3 Какие типовые подходы были использованы к выполнению каждой 

проектной процедуры? 
4.4.4 Сформулируйте  задачу параметрической оптимизации как задачу 

математического программирования. 
4.4.5 Приведите примеры критериев оптимальности. 
4.4.6 Как сформировать критерий оптимальности в программе PSpice 

Optimizer. 
4.4.7 Как выбрать состав и диапазон значений  варьируемых параметров? 
4.4.8 Как  зависит  сложность  задачи  оптимизации от числа варьируемых 

параметров?  
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5 Оптимизация допусков 
 
5.1 Краткие сведения из теории 
 
Цель работы - приобрести практические  навыков  решения задачи опти-

мизации допусков на параметры электрорадиоэлементов (ЭРЭ) на этапе схемо-
технического проектировании.  

Методика решения задачи рассматривается на примере активных RC-
фильтров,  условия  работоспособности  которых  заданы в графиком попусков 
для АЧХ. 

Среди задач схемотехнического проектирования РЭУ наиболее сложной 
и трудоемкой является задача выбора оптимальных  допусков на параметры 
ЭРЭ.  Она решается при выбранной структуре устройства и после расчета (оп-
тимизации) значений  параметров ЭРЭ. При промышленном проектировании 
расчетные значения параметров ЭРЭ должны быть заменены номинальными 
значениями из стандартных рядов (для  постоянных резисторов и для постоян-
ных конденсаторов определяются ГОСТ 28884-90). Реальные значения пара-
метров ЭРЭ распределяются случайным образом около номинальных значений 
в пределах производственных допусков и приводят к производственному раз-
бросу выходных параметров РЭУ. 

Оценка правильности функционирования РЭУ устройства производится 
по выполнению условий работоспособности, представляющих собой требуемые 
соотношения между значениями выходных параметров yi и граничными значе-
ниями Ti (техническими требованиями), указанными в ТЗ. Для рассматривае-
мой задачи условия  работоспособности имеют вид 
 

maxmin jjj TyT <<  .                                                    (5.1) 
 

где  yj - значение АЧХ на частоте Fj. 
Этим обеспечиваются  запасы работоспособности 

 

))(,)(min()( 0min0max0 XXX jjjjj yTyTa −−=                              (5.2) 
 
Область  в пространстве параметров ЭРЭ, в которой все условия работо-

способности выполняются, называется областью работоспособности. Задача 
оптимизации допусков может быть геометрически интерпретирована, как зада-
ча вписывания в область работоспособности допусковой области, задаваемой 
неравенствами 
 

xio+∆x imax < xi < x io+∆ximax ,                                           (5.3) 
 

где  x io - номинальное значение параметра i-го ЭРЭ; 
         ∆x imax - абсолютное значение его допуска.  
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Для снижения стоимости проектируемого РЭУ следует стремиться к ре-
шению задачи с максимально возможными значениями относительных допус-
ков  ti = ∆x imax/xio. 

Известны различные методы решения подобных задач, в данной лабора-
торной работе используется метод равных влияний [2]. 

Предположим, что в пределах области работоспособности значения 
функций чувствительности существенно не меняются. Тогда использование их 
значений в опорной точке X0, координаты которой задаются номинальными 
значениями параметров ЭРЭ, позволяет обеспечить допустимую погрешность 
метода. Будем полагать, что разброс параметров интегральных ОУ, охваченных 
глубокой отрицательной обратной связью, существенно не  влияет на разброс 
выходных параметров и его можно не учитывать. 

Тогда, полагая равный вклад отклонений параметров ЭРЭ в отклонение 
выходного параметра, получим 
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где m - число параметров всех ЭРЭ, принимаемых во внимание; 

         k – коэффициент, зависящий от планируемого процента выхода год-
ных изделий (для 68 % - k = 1,  для 95 % - k = ½,  для 99.8 % - k = 1/3); 

       li - коэффициент, зависящий от закона распределения параметров 
ЭРЭ (для нормального закона li  = 1/3,  для равномерного закона 31=il ). 

         )(Xj

i

y
xS - функция относительной чувствительности yj  к вариации па-

раметра xi . 
С экономической и технологической точек зрения целесообразно ввести 

весовые коэффициенты, позволяющие определять вклад отклонений парамет-
ров ЭРЭ в соответствии с зависимостями допуск – стоимость. Для ЭРЭ, у кото-
рых рост стоимости при снижении значений допусков выше, следует устано-
вить более высокие значения весовых коэффициентов wi , тогда  
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где  wj  -  весовой коэффициент, задаваемый по критерию равноценности 

допусков  различных ЭРЭ с технологической и экономической точек зрения.  
Рассчитанные значения допусков должны быть заменены допустимыми  для 
данных ЭРЭ стандартными значениями (в процентах) из ряда: 

20, 10, 5, 2, 1, 0.5, 0.2, 0.1, 0.05, 0.02, 0.01 , 
при сохранении выполнения условий работоспособности. 



 27

По результатам расчета допусков необходимо выбрать подходящий ряд 
номинальных значений параметров и заменить расчетные значения параметров 
ЭРЭ номинальными значениями из стандартного ряда. Ряды для определения 
номинальных сопротивлений и емкостей приведены в таблицах 5.1 и 5.2 

 
Таблица 5.1 - Ряды номинальных значений параметров при  
допускаемых отклонениях 20, 10, 5 % 

 
 

Таблица 5.2 - Ряды номинальных значений параметров при  
допускаемых отклонениях менее 5 % 

 
 
С помощью  программы  PSpice AD можно рассчитать значения функций 

чувствительности и выполнить оценку разброса  частотных  характеристик для 
заданных значений допусков пассивных ЭРЭ. 

 
5.2 Описание последовательности выполнения задания 
 
Открыть проект \CAD\LR4\Bp6 командой File\Open\Project. 
Открыть в менеджере проекта схему РЭУ SCHEMATIC1:PAGE1. 
Выполнить редактирование параметра AC=1 источника входного сигнала 

Vg.  
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Выполнить редактирование профиля моделирования командой PSpice> 
Edit Simulation Profile для расчета разброса частотных характеристик по наи-
худшему случаю и значений чувствительностей, для этого на закладке Analysis: 

- установить вид анализа (Analysis type) – AC Sweep/Noise; 
- установить флажок для опции Monte Carlo/Worst Case; 
- выбрать вид анализа Worst-case/Sensitivity и выходную переменную 

V(2); 
- нажать кнопку More Setting, задать Find: The maximum Value (MAX), 

выбрать Worst-Case direction: Hi;  
- для опции General Setting задать закон изменения AC Sweep Type: 

Logarithmic/Decade и пределы изменения частоты (Start Frequency = 500, End 
Frequency = 2000, Points/Decade = 100); 

- закрыть окно редактирования нажатием кнопки OK. 
Выполнить моделирование  командой PSpice>Run. При этом выполняет-

ся запуск программы PSpice AD. 
Вывести на экран график АЧХ, для этого командой Trace>Add Trace от-

крыть окно Add Trace и в окне Trace Expression задать значение (V(2)), под-
твердить выбор нажатием клавиши ОК. Зарисовать график разброса АЧХ.  

Определить значения функций чувствительности командой View> Output 
File.  

Используя найденные значения функций чувствительности по формуле 
(5.5)  определить допуски на параметры ЭРЭ. Заменить рассчитанные значения 
допусков стандартными значениями. Присвоить эти значения параметрам 
Tolerance элементов схемы. 

Выполнить расчет разброса частотных характеристик методом Монте-
Карло, для этого на закладке Analysis: 

- выбрать вид анализа Monte-Carlo, выходную переменную V(2), число 
испытаний Number of Runs: 10; равномерный закон распределения Use 
Distribution: Uniform; 

- закрыть окно редактирования нажатием кнопки OK. 
Выполнить моделирование  командой PSpice>Run. При этом выполняет-

ся запуск программы PSpice AD. 
Вывести на экран график АЧХ, для этого командой Trace>Add Trace от-

крыть окно Add Trace и в окне Trace Expression задать значение (V(2)), под-
твердить выбор нажатием клавиши ОК. Зарисовать график разброса АЧХ.  

Оценить полученные результаты. Принять решение о прекращении или 
продолжении процесса оптимизации допусков. 

Заменить расчетные значения параметров ЭРЭ номинальными значения-
ми из стандартных рядов, соответствующих найденным значениям допусков. 

Выполнить анализ  рассеяния  частотных  характеристик. Если условия 
работоспособности не выполняются, принять решение относительно дальней-
ших действий: 

- попытаться выбрать другие номинальные значения параметров ЭРЭ 
(допускается  использование  последовательно  или  параллельно включенных 
пассивных ЭРЭ); 
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- продолжить решение задачи оптимизации допусков; 
- определить ЭРЭ, параметры которых необходимо подбирать при регу-

лировке. 
  

5.3 Оформление  отчета 
  
Отчет по лабораторной работе должен содержать: 
- функциональную схему фильтра; 
- расчетные значения параметров ЭРЭ и их допусков; 
- найденные номинальные значения параметров ЭРЭ и стандартные зна-

чения их допусков; 
- результаты анализа рассеяния частотных характеристик фильтра и срав-

нения их с заданными условиями работоспособности. 
 

5.4 Контрольные вопросы 
 

5.4.1 Дайте геометрическую интерпретацию задачи оптимизации допус-
ков. 

5.4.2 Перечислите способы нормирования внутренних параметров и кри-
терии оптимальности в задачах оптимизации допусков. 

5.4.3 Перечислите методы решения задачи оптимизации допусков. 
5.4.4 Как влияют значения допусков ЭРЭ  на  технико-экономические по-

казатели электронных устройств? 
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6 Функционально-логическое моделирование  
 

6.1 Краткие сведения из теории 
 

Цель занятия - получить практические навыки решения типовых задач 
анализа цифровых РЭУ на этапе функционально-логического проектирования. 

Методы и средства функционально-логического моделирования позволя-
ют эффективно решать основные задачи анализа цифровых РЭУ: логическую и 
временную верификацию. Логическая верификация направлена на выявление 
соответствия работы цифрового РЭУ заданному алгоритму функционирования. 
Временная верификация направлена на оценку быстродействия и выявление 
рисков сбоя.  

Чтобы выполнить логическую верификацию, необходимо определить  ус-
тановившиеся значения выходных сигналов (выходные наборы) для всех задан-
ных комбинаций входных сигналов (входных наборов). Промежуточные значе-
ния  сигналов, формируемые во время переходных процессов, во внимание не 
принимаются. Если все полученные значения совпадают с заданными, то это 
позволяет сделать вывод о правильности синтеза цифрового РЭУ. Выявленные 
отличия свидетельствует о допущенных ошибках при синтезе.  

Упорядоченную последовательность входных наборов называют тестом. 
Для цифровых РЭУ комбинационного типа последовательность поступления 
входных наборов не имеет значения. Для цифровых РЭУ последовательностно-
го типа (автоматов с памятью) значения выходных сигналов зависят не только 
от текущих значений входных сигналов, но и от состояния элементов памяти до 
выполнения  перехода. Поэтому порядок следования входных наборов должен 
удовлетворять условию: исходное состояние элементов памяти в текущем ва-
рианте моделирования должно совпадать с результирующим состоянием, рас-
считанным для предыдущего варианта моделирования.  

Длительность формирования каждого из входных наборов определяется 
по условию завершения переходных процессов между последовательными из-
менениями входных сигналов. 

Для временной верификации выполняют анализ характера переходных 
процессов при переключении элементов цифрового РЭУ. В качестве оценки 
быстродействия цифровых РЭУ комбинационного типа используют:  

 
tзр = max tзр ij  ,          (6.1) 
   j=1,m; i=1,n 

 
где tзр ij  - задержка распространения сигнала от  i–го входа до j-го выхода. 

Величину tзр  определяют как задержку фронта выходного сигнала yj относи-
тельного вызвавшего его фронта входного сигнала xi .  

Задержки сигналов в элементах и линиях связи цифровых РЭУ сущест-
венно влияют на их функционирование. Задержки в комбинационных схемах 
(КС) не только ограничивают быстродействие, но могут также приводить к по-
явлению на их выходах временно существующих ложных значений сигналов. 
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Со временем они исчезают, но являются опасными, если выход КС связан с 
входом триггера.   В этом случае воздействие ложного сигнала может изменить 
состояние триггера и привести к ошибке, не исчезающей со временем.  

Реальные значения задержек определяются большим числом факторов 
(емкость нагрузки логических элементов,  электрические параметры линий свя-
зи и т.д.), поэтому появление ложных  сигналов на выходах КС можно рассмат-
ривать как случайные события, которые называют рисками сбоя. Различают 
статические и динамические риски сбоя. Статические риски сбоя возникают, 
когда выходной сигнал по логике работы должен оставаться неизменным, но 
происходит его кратковременное изменение типа 1-0-1 (статический 1-риск 
сбоя) или типа 0-1-0 (статический 0-риск сбоя). Динамические  риски сбоя воз-
никают, когда вместо предусмотренного однократного изменения уровня вы-
ходного  сигнала 0-1 или 1-0 происходят многократные изменения 0-1-0-1 или 
1-0-1-0.  

На рисунке 6.1 приведена КС, выход которой подключен к асинхронному 
RS-триггеру. КС реализует функцию  
 

⎯ s  =⎯ x1 ⋅ x3 + x1⋅ x2 .                                                           (6.2) 
 
При x2=1, x3=1  

 

⎯ s  =⎯ x1 + x1 ,                                                                      (6.3) 
 

и по законам алгебры логики ⎯ s  = 1. Однако изменения сигнала x1 распростра-
няются по двум путям с соответствующими задержками: 

- через элемент DD2; 
- через элементы DD1, DD3, 

и на входы элемента DD4 эти изменения приходят не одновременно. На выходе 
DD4 кратковременно формируется ложное значение сигнала, которое может вы-
звать ложное срабатывание триггера.  
 

 
Рисунок 6.1 

 
В подобных случаях для устранения статических рисков сбоя в КС можно 

при минимизации исходной функции склеивать все соседние группы клеток 
карты Карно, как показано на рисунке 6.2.  В  результате получим 
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⎯ s  =⎯ x1 ⋅ x3 + x1⋅ x2 + x2⋅ x3.                                                 (6.4) 
 
При x2=1, x3=1  
 

⎯ s  =⎯ x1 + x1 + 1 = 1.                                                        (6.5) 
 
Построенные таким образом КС называются свободными от состязаний.  

                                                               
                                                                x3 x2 

        x1     00     01     11    10 
        0 0 0 1 1 

        1 0 1 1 0 
 

Рисунок 6.2 
 
Если риск сбоя возникает в результате разновременности изменений (со-

стязания) входных сигналов КС, то данный прием неэффективен (подумайте 
почему).  

Эффективный прием борьбы с критическими состязаниями - синхрониза-
ция, с помощью которой запись данных в триггеры разрешается внешним сиг-
налом CLK только в определенные моменты времени после завершения пере-
ходных процессов на входах данных. При использовании триггеров, синхрони-
зируемых фронтом, данные не должны изменяться на интервалах предустанов-
ки tSU и удержания tH относительно активного фронта сигнала CLK.  
 

6.2 Описание последовательности выполнения задания 
 
6.2.1 Логическая верификация и оценка быстродействия 
 
Активизировать окно программы OrCAD Capture. Открыть проект 

\CAD\LR6\Vd<n> командой File>Open>Project, где <n> - номер варианта. От-
крыть в менеджере проекта схему цифрового РЭУ  SCHEMATIC1: PAGE1. 

Сформировать тест для логической верификации. Запустить программу 
PSpice Stimulus Editor. Выполнить команду File>New. 

Последовательно выполнить формирование цифровых сигналов командой 
Stimulus>New, для этого в открывшейся панели выбрать тип сигнала (Signal) и 
в строке Name указать его имя, которое должно совпадать с обозначенным на 
схеме (значение параметра Implementation соответствующего элемента 
DigStim1).  

При необходимости выполнить редактирование цифровых сигналов, для 
этого активировать клавишу Add a new point or Transition to a Stimulus (при 
этом курсор примет вид карандаша), подвести курсор к графику сигнала, где 
необходимо поставить переход (изменить его значение), и нажать левую кнопку 
мыши. После завершения расстановки переходов нажать правую кнопку мыши 
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(при этом курсор примет обычный вид). При необходимости предварительно 
выделенный переход (нажатием левой кнопки мыши) можно удалить командой  
Edit>Delet или “отбуксировать” при нажатой левой клавиши мыши. 

Сохранить файл сигналов командой File>Save As, назначив имя Vd<n>, 
где <n> - номер варианта. Завершить работу с программой Stimulus Editor.  

Активизировать окно программы OrCAD Capture. Выполнить редактиро-
вание профиля моделирования командой PSpice>Edit Simulation Profile для 
моделирования цифрового устройства, для этого на закладке Analysis: 

- задать вид анализа (Analysis type) – Time Domain (Transient); 
- задать значение времени моделирования Run to time; 
- на закладке Stimulus выбрать нажатием на кнопку Browse и подключить 

к проекту файл сигналов нажатием на кнопку Add to Design, закрыть окно ре-
дактирования нажатием кнопки OK. 

Выполнить моделирование цифрового РЭУ командой PSpice>Run. 
Вывести на экран временные диаграммы входных и выходных сигналов, 

для этого командой Trace>Add Trace открыть окно Add Trace и выбрать соот-
ветствующие сигналы, подтвердить выбор нажатием клавиши ОК. Зарисовать 
временные диаграммы в отчет. Определить задержки. Удалить диаграммы ко-
мандой Trace>Delete All Traces. Сделать вывод о соответствии работы схемы 
алгоритму функционирования. 

 
6.2.2. Анализ рисков сбоя 

 
Открыть проект \CAD\LR6\Risk1. Открыть в менеджере проекта схему 

цифрового РЭУ  SCHEMATIC1: PAGE1. 
Сформировать тест для исследования рисков сбоя. Запустить программу 

PSpice Stimulus Editor. Сформировать модели сигналов x1 и⎯ r , которые обеспе-
чивают сброс триггера, затем изменение x1  0-1, а затем 1-0. Сохранить файл 
сигналов. Завершить работу с программой Stimulus Editor.  

Активизировать окно программы OrCAD Capture. Выполнить редактиро-
вание профиля моделирования. Выполнить моделирование цифрового РЭУ. 

Вывести на экран временные диаграммы сигнала x1  и сигналов на выхо-
дах логических элементов. По диаграммам сигналов определить, как работает 
схема. Зарисовать временные диаграммы в отчет. Удалить диаграммы. 

Выполнить редактирование профиля для моделирования с нарастающей 
неопределенностью: 

- на закладке Options выбрать Category: Gate Level Simulation, в панели 
Timing mode задать Worst case. Повторить расчет. По диаграммам сигналов оп-
ределить, как работает схема.  

Изменить комбинационную схему в соответствии с картой Карно на ри-
сунке 6.2. Выполнить моделирование с нарастающей неопределенностью. По 
диаграммам сигналов определить, как работает схема.  

Заменить асинхронный триггер на синхронный 155ТМ2 из библиотеки 
7400.olb. Внести необходимые изменения в схему. Выполнить редактирование 
моделей сигналов. Выполнить моделирование с типовыми значениями задер-
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жек и с нарастающей неопределенностью. Экспериментально определить мак-
симальное значение тактовой частоты, при которой сохраняется работоспособ-
ность схемы. Принять во внимание, что для триггера К155ТМ2 tSU = 20 нс, tH = 
4 нс.    

Сделать выводы о характере оценок, которые дают методы моделирова-
ния с фиксированными задержками и нарастающей неопределенностью. Сде-
лать вывод об эффективности исследованных способов устранения статических 
рисков сбоя.   

 
6.3 Оформление  отчета 

  
Отчет должен содержать: 
- обоснование теста, временные диаграммы входных и выходных сигна-

лов цифрового РЭУ; 
- анализ результатов моделирования (вывод о правильности работы РЭУ 

и значения задержек); 
- временные диаграммы сигналов, полученные при исследовании рисков 

сбоя 
- анализ результатов моделирования рисков сбоя (выводы). 

 
6.4 Контрольные вопросы 

 
6.4.1 Перечислите задачи анализа цифровых РЭУ. Кратко сформулируйте 

их содержание. 
6.4.2 Как сформировать тест для логической верификации цифровых РЭУ 

комбинационного и последовательностного типа? 
6.4.3 Как можно оценить задержки распространения сигналов в цифровых 

РЭУ? 
6.4.4 Что такое риск сбоя? Из-за чего они возникают? 
6.4.5 Как отличаются оценки рисков сбоя, которые дают методы асин-

хронного  моделирования с фиксированными задержками и нарастающей неоп-
ределенностью? 

6.4.6 Как можно оценить значение максимальной тактовой частоты для 
синхронных цифровых РЭУ? 
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7 Компоновка и размещение 
 
7.1 Краткие сведения из теории 

 
Цель занятия - изучить команды и получить практические навыки по ра-

боте со средствами автоматизированного проектирования печатных плат. 
Исходные данные для разработки печатной платы (ПП) должны быть 

представлены принципиальной электрической схемой РЭУ, созданной с помо-
щью графического редактора OrCAD Capture. Принципиальная схема опреде-
ляет полный состав элементов и связи между ними. На ней изображаются все 
электрические элементы и устройства, все электрические связи между ними, а 
также элементы (соединители, зажимы и т.п.), которыми заканчиваются вход-
ные и выходные цепи. 

Основными  задачами  синтеза  конструкций РЭУ являются задачи ком-
поновки и размещения конструктивов, трассировки монтажных  соединений. 
Задача компоновки заключается в определении схемного состава  типовых кон-
струкций каждого иерархического уровня. Например, схемного состава конст-
руктивов низших уровней – компонентов и ячеек. 

Решение  задач компоновки очень тесно связано с процессом перевода 
проекта из подсистемы функционального проектирования в подсистему конст-
рукторского проектирования,  т.е.  с  преобразованием описания  проектируе-
мого  устройства, полученного в результате выполнения этапов функциональ-
ного и  схемотехнического  проектирования,  к новому виду, пригодному для 
решения конструкторских задач. В ходе выполнения такого преобразования 
происходит замена функциональных атрибутов объектов конструкторскими, 
при сохранении информации о связях между объектами. Преобразование опи-
саний проектируемого устройства может быть выполнено с промежуточным 
представлением описания на входном языке подсистемы конструкторского 
проектирования с последующей трансляцией. 

Это промежуточное описание в виде списка соединений схемы в формате 
Layout, приемлемом для программы OrCAD Layout, формируется по команде 
Tools>Create Netlist. Результат сохраняется в файле <имя>.MNL. 

Разработка новой ПП начинается после загрузки OrCAD Layout и выпол-
нения команды File>New. Сначала запрашивается имя технологического шаб-
лона ПП (расширение имени файла *.ТСН или *.TPL, затем — имя файла спи-
ска соединений *.MNL. В заключение указывается имя файла создаваемой ПП 
*.МАХ.  

В процессе загрузки списка соединений для каждого символа схемы в 
библиотеках корпусов компонентов *.LLB (Footprint Libraries) отыскивается 
соответствующий корпус. Это соответствие указывается с помощью атрибута 
символа РСВ Footprint. Если в процессе загрузки списка соединений обнаружен 
компонент, не имеющий ссылок на его корпус, то выводится диалоговое окно 
для его определения. После нажатия на кнопку Link existing footprint to 
component (Свяжите существующий типовой корпус с компонентом) открыва-
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ется диалоговое окно, в котором выбирается имя библиотеки и затем имя кор-
пуса, изображение которого просматривается в правой части окна.  

Технологические шаблоны (Technology templates, файлы с расширением 
имени *.ТСН или *.TPL) содержат начальную информацию о ПП: зазоры и сет-
ка трассировки, данные о контактных площадках (КП) и переходных отверсти-
ях (ПО) и т.п. В дальнейшем все эти установки можно изменить по отдельности 
или загрузить новый шаблон после создания ПП. В результате загрузки техно-
логического шаблона в текущий проект вносятся следующие изменения:  

- загружаются стратегии размещения компонентов и трассировки провод-
ников, замещая предыдущие данные;  

- устанавливается новая структура слоев ПП;  
- изменяются размеры шагов всех сеток:  
- изменяются параметры всех стеков контактных площадок (СКП) выво-

дов компонентов и ПО.  
Для создания файла технологического шаблона необходимо создать файл 

ПП, выполнив необходимые установки, и сохранить его с явным указанием 
расширения имени ТСН или TPL. Вместе с OrCAD Layout поставляется ряд 
шаблонов. Рекомедуется использовать шаблон lbet_any.tch — для ПП, предна-
значенных для установки компонентов как со штыревыми, так и с планарными 
выводами (между выводами стандартных корпусов DIP допускается прокладка 
одной трассы).  

После успешного завершения загрузки списка соединений на рабочем эк-
ране OrCAD Layout изображаются корпуса компонентов текущего проекта с 
указанием их электрических соединений.  

Наиболее употребительные команды OrCAD Layout имеют пиктограммы 
быстрого вызова на панели Toolbar. Однако две пиктограммы не имеют соот-
ветствующих команд. Это пиктограммы включения режима текущей проверки 
Online DRC и отключения видимости электрических связей Reconnect Mode. 
Состояния этих режимов отображаются в строке заголовка основного меню: 
DRC ON/OFF, RECONNECT ON/OFF.  

В начале по команде Options>System Settings (Ctrl+G) в диалоговом ок-
не просматривают и при необходимости редактируют глобальные параметры 
проекта:  

- Display Units - выбор системы единиц (Miles, Inches, Milimeters, 
Centimeters);  

- Display Resolution — разрешающая способность изображения в декарто-
вой системе координат;  

- Rotation - - поворот объектов (угол поворота при выполнении команды 
Rotate и угловая разрешающая способность);  

- Workspace Settings — размеры рабочей области.  
Затем по команде View >Database Spreadsheets>Layers в диалоговом ок-

не просматривают и при необходимости редактируют перечень слоев ПП и их 
назначение. Редактирование слоев производится с помощью меню, раскры-
вающихся после щелчка правой кнопкой мыши. Слои ПП могут быть следую-
щих типов:  
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- Routing — трассировки;  
- Plane — металлизации (обычно слои «земли» и «питания»); изобража-

ются негативным образом (участки металлизации высветлены, а участки осво-
бождения затемнены);  

- Drill — символов отверстий;  
- Jumper — перемычек;  
- Documentation — документирования;  
- Unused — неиспользуемый слой.  
ПП по умолчанию содержит два наружных слоя (ТОР, ВОТ), два слоя ме-

таллизации (GND, POWER), 12 внутренних слоев (INNER1, ..., INNER12), слой 
символов отверстий DRILL и 10 слоев документирования. Слои можно пере-
именовывать, изменять их тип, добавлять новые, их нельзя только удалять. Ка-
ждый слой помимо основного имени Layer Name (например TOP, BOTTOM, 
INNER1) имеет трехсимвольное уменьшительное имя NickName (TOP, ВОТ, 
GND, IN1 и др.), которое не редактируется. Дополнительный слой Global Layer 
предназначен для отображения электрических связей.  

При наличии в проекте планарных компонентов в графе Mirror Layer для 
каждого слоя при необходимости указывается имя слоя, на который переносит-
ся соответствующая информация при переносе компонента на противополож-
ную сторону ПП.  

Далее по команде View >Database Spreadsheets>Padstacks в диалоговом 
окне  просматривают и при необходимости редактируют перечень стеков кон-
тактных площадок (КП) выводов компонентов и переходных отверстий (ПО).  

В диалоговом окне редактирования параметров (Properties) КП и ПО рас-
положены следующие панели:  

- Non-Plated — признак наличия сквозного отверстия;  
- Use For Test Point — признак использования ПО в качестве контроль-

ной точки (test point);  
- Large Thermal Relief — признак использования КП в качестве большо-

го теплового барьера, располагаемого на слое металлизации;  
- Pad Shape - форма КП (Round — круглая, Square — квадратная, Oval — 

овальная, Annular — в виде кольца, Oblong — продолговатой формы со скруг-
ленными краями; Rectangle — прямоугольная, Thermal Relief - тепловой барьер; 
Undefined — не определена);  

- No Connection — невозможность подключения к КП электрических це-
пей (используется для блокировки подключения цепей на определенных слоях);  

- Pad Width — ширина КП;  
- Pad Height — длина КП;  
- X/Y Offset — смещение точки подключения трассы относительно гео-

метрического центра КП по осям X/Y.  
Перед выполнением размещения компонентов необходимо вычертить 

контур ПП Board outline. Для этого в меню Tool выбирается команда Obstacle и 
вычерчивается замкнутый многоугольник; тип барьера (в данном случае Board 
Outline), слой размещения и толщина линий контура которого задается в диало-
говом окне.  
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При  проектировании узлов с печатным монтажом задача размещения со-
стоит в определении местоположения компонентов в монтажном пространстве 
ПП, при котором создаются наилучшие условия для последующего решения 
задачи трассировки печатных соединений с учетом конструкторско-
технологических требований и ограничений: 

- компоненты должны быть установлены на  ограниченной  части плоско-
сти заданной конфигурации; 

- при односторонней установке компонентов их проекции на плоскость 
размещения не должны пересекаться; 

- между компонентами должны соблюдаться необходимые зазоры. 
Монтажное пространство ПП ограничивается заданным  типоразмером  

ТЭЗ, в ограниченном пространстве могут располагаться области, запрещенные 
для размещения компонентов, зарезервированные для других целей. Компонен-
ты со штыревыми выводами, как правило, устанавливаются на одной стороне 
ПП (стороне монтажа). Компоненты, монтируемые на поверхность, допускает-
ся устанавливать на обеих сторонах ПП (стороне монтажа и стороне пайки).  
Гибкие выводы компонентов должны формоваться таким образом, чтобы нахо-
диться в узлах координатной сетки ПП. Жесткие штыревые и планарные выво-
ды ИС, как правило, расположены с шагом, кратным стандартному шагу  коор-
динатной сетки ПП (1.25 или 2.5 мм), и должны располагаться в ее узлах. 

Под благоприятными условиями для трассировки понимается такое раз-
мещение, при котором части  рабочего  поля  ПП  при  проведении трасс печат-
ных проводников будут использоваться наиболее равномерно. В качестве фор-
мальных критериев качества размещения на этапе решения задачи используют-
ся: минимум суммарной длины всех соединений; минимум числа пересечений  
проводников; максимально близкое расположение компонентов, имеющих  
наибольшее число связей между собой и др. 

Формальные алгоритмы размещения, используемые в автоматическом 
режиме проектирования, основаны на решении  задачи  назначения компонен-
там посадочных мест с определенными координатами. Для задач размещения  
можно использовать регулярное монтажное пространство, в котором посадоч-
ные места располагаются в узлах равномерной  сетки. Результат авторазмеще-
ния можно доработать в интерактивном режиме.  

Размещение таких компонентов, как разъемные соединители рекоменду-
ется выполнять в интерактивном режиме, по очереди выбирая, перемещая, по-
ворачивая компоненты на поверхности наружного слоя ПП и перемещая пла-
нарные компоненты на противоположную сторону. После размещения компо-
нента его следует зафиксировать (команда Fix в меню, которое открывается при 
нажатии правой кнопки мыши). В непосредственной близости от соединителей 
необходимо разместить полярные конденсаторы, установленные для фильтра-
ции помех в цепях питания. 
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Остальные компоненты рекомендуется размещать в автоматическом ре-
жиме на регулярной сетке посадочных мест. Чтобы создать сетку, необходимо в 
меню Tools выполнить команду Matrix>Select Tool. Отметить курсором верх-
ний правый угол окна размещения, а затем, не отпуская кнопки мыши, отме-
тить нижний левый угол. Перемещая курсор в обратном направлении задать 
сетку посадочных мест с необходимым шагом.  

Чтобы выполнить авторазмещение компонентов, необходимо: 
- активировать кнопку Component button на панели Toolbar;  
- выбрать группу компонентов для размещения; 
- в меню Auto выполнить команду Place>Matrix.  
Качество размещения можно оценить по гистограмме плотности связей 

(команда View>Density Graph>Fine). 
 

7.2 Описание последовательности выполнения задания 
 
7.2.1 Доработать функциональную схему до уровня принципиальной. 
7.2.2 Подготовить список соединений схемы в формате Layout. 
7.2.3 Установить требуемые для работы параметры программы Layout 

командой System Settings (меню Options). 
7.2.4 Сформировать базу данных новой ПП. 
7.2.5 Сформировать Board Outline. 
7.2.6 Выполнить размещение компонентов. 
7.2.7 Оценить качество размещения. 
 
7.3 Оформление  отчета 

  
Отчет должен содержать: 
- эскиз размещения компонентов; 
- оценки качества размещения. 

 
7.4 Контрольные вопросы 
 
7.4.1 К какому этапу проектирования относится выполненная работа? 
7.4.2 Сформулируйте содержание и цели задач компоновки. 
7.4.3 Перечислите основные критерии оптимальности в задачах разреза-

ния и покрытия. 
7.4.4 Сформулируйте содержание и цели задачи размещения конструкти-

вов. 
7.4.5 Перечислите ограничения и критерии оптимальности для задачи 

размещения. 
7.4.6 Перечислите  требования  стандартов,  выполнение которых должно 

быть обеспечено при размещении компонентов на печатных платах. 
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8 Трассировка печатного монтажа 
 
8.1 Краткие сведения из теории 
 
Цель занятия - получить практические навыки трассировки печатного 

монтажа в среде САПР. 
Трассировка заключается в определении топологии и метрических пара-

метров элементов печатного  или  проводного  монтажа, реализующего соеди-
нения между элементами схемы. Исходные данные для трассировки:  список  
цепей, метрические  параметры и топологические свойства типовой конструк-
ции и ее элементов, результаты решения задачи размещения, по которым нахо-
дят координаты выводов элементов  конструкции. Формальная постановка  за-
дачи  трассировки и методы ее решения в значительной степени зависят от вида 
монтажа  и  конструкторско-технологических ограничений, определяющих  
метрические параметры и топологические свойства монтажного пространства. 

В типовых конструкциях на уровне типового элемента замены (ТЭЗ),  
ячейки в основном используется печатный монтаж. В лабораторной работе рас-
сматривается автоматизированное решение  задачи  трассировки печатных со-
единений в конструктивах на уровне ТЭЗ, т.е. при проектировании узлов с пе-
чатным монтажом. Различают одно-, двух- и многослойные  ПП  (ОПП, ДПП и 
МПП) в зависимости от числа слоев формируемых систем печатных  проводни-
ков. К числу важнейших  метрических  параметров  и  топологических свойств 
монтажного пространства ПП относятся: 

- геометрические размеры и форма поля трассировки ПП; 
- шаг координатной сетки; 
- координаты и размеры областей запрещенных для  трассировки и заре-

зервированных для других целей; 
- число слоев и возможность перехода со слоя на слой; 
- координаты и размеры КП; 
- ширина печатных проводников и зазоры  между  проводниками, между 

проводником и КП. 
ГОСТ 10317-79 определяет основной шаг координатной сетки 2.5 мм, для 

ПП с высокой плотностью монтажа  допускается  использовать шаг 1.25 и 0.625 
мм. Чтобы ПП была технологичной, разработку конструкции  следует  вести,  
ориентируясь  на конкретную промышленную технологию изготовления. МПП 
целесообразно применять при высоких требованиях к плотности электрическо-
го монтажа, в основном для реализации цифровых ТЭЗ, выполненных на БИС. 
Переходы со слоя на слой  могут быть  реализованы только за счет использова-
ния штыревых выводов компонентов и сквозных отверстий, или также за счет 
межслойных переходов - КП и металлизированных отверстий, специально  из-
готавливаемых  для этих целей. Реализация межслойных  переходов  повышает 
стоимость изготовления ПП. 

Печатные  проводники  рекомендуется  выполнять  прямоугольной фор-
мы, допускается произвольная форма и скругление изгибов. Ширину печатных  
проводников необходимо выдерживать по всей длине. Допустимые размеры и 
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величины зазоров для ПП различных классов точности (по ГОСТ 23751- 86) 
приведены в таблице 8.1.  Допускается  "подрезание" круглых КП, при прохож-
дении трасс проводников между ними для обеспечения  требуемых зазоров. В 
МПП шины "земли" и питания реализуют в отдельных специальных слоях, в 
ОПП и ДПП они реализуются более широкими печатными проводниками. На-
пример, для цифровых РЭУ рекомендуется шины "земли" и питания выполнять 
шириной не менее 2.5 мм или  в  виде навесных "вырубных" шин. 

 
Таблица 8.1 

Класс точности 
Размеры элементов печатного монтажа  

1 2 3 4 5 
Ширина  проводников, мм 0.75 0.45 0.25 0.15 0.10 
Зазоры между проводниками, мм 0.75 0.45 0.25 0.15 0.10 
Зазоры между проводником и контактной 
площадкой, мм 

0.75 0.45 0.25 0.15 0.10 

 

К числу формальных критериев качества трассировки печатных провод-
ников относятся: минимум суммарной длины  проводников;  минимум  числа  
их пересечений; минимум изгибов проводников; минимум числа слоев и пере-
ходов со слоя на слой; равномерное распределение проводников в монтажном 
пространстве. При  ограничениях на число слоев (особенно для ОПП и ДПП) 
применение последовательных алгоритмов автотрассировки не гарантирует  
полную трассировку всех соединений, доразводку нереализованных цепей 
обычно выполняют в интерактивном или ручном режиме. 

В среде программы OrCAD Layout трассировка проводников в ручном 
режиме выполняется с помощью команд Tool>Track>Select Tool и Track 
Segment,  а в в интерактивном режиме - с помощью команд Auto>Autoroute 
(Autopath Route Mode, Shove Track Mode, Edit Segment Mode ). При интерак-
тивной трассировке выполняется текущий контроль соблюдения допустимых 
зазоров, если включен режим Online DRC. 

OrCAD Layout содержит в меню Auto группу команд, достаточных для 
автотрассировки простых ПП. Для разработки более сложных ПП предназначе-
на программа SmartRoute, использующая алгоритмы оптимизации нейронных 
сетей. Требуемую ширину трасс проводников можно задать командой Nets в 
меню Tool. 

Частные параметры стратегии автотрассировки задаются в диалоговых 
окнах, которые открываются по командам Options>Route Strategies программы 
OrCAD Layout. Глобальные параметры стратегии автотрассировки задаются в 
диалоговом окне, которое открывается по команде Options>Route Settings.  

Программа SmartRoute вызывается из начального меню программы 
OrCAD Layout или автономно. Сначала загружается файл ПП *.МАХ и затем с 
помощью команд меню Setup задаются параметры трассировки в диалоговых 
окнах. В нижней части окна Parameters после нажатия на панель Analyze 
Parameters указываются оценки полноты трассировки в процентах и ожидаемые 
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затраты времени (эти данные весьма приблизительные и для сложных ПП не 
всегда соответствуют фактическим результатам). При этом надо учитывать, что 
из OrCAD Layout в SmartRoute передаются значения ширины трасс всех цепей 
(Track Width) и допустимые зазоры (Clearance).  

В заключение по команде Options>Routing Passes задается перечень про-
ходов трассировки (ROUTING PASSES) и проходов улучшения технологично-
сти платы (MANUFACTURING PASSES). Автотрассировка начинается по ко-
мандам меню Auto. Кроме того, в программу SmartRoute включены команды 
трассировки цепей в ручном режиме Tools>Manual Route и Tools>Sketch a 
Track. Если SmartRoute загружен из оболочки OrCAD Layout, то по окончании 
трассировки управление передается обратно (однако файлы ПП из одной про-
граммы в другую автоматически не передаются).  

В качестве исходных данных для трассировки  при выполнении  лабора-
торной работы следует использовать БД проекта, сформированную в ходе вы-
полнения лабораторной  работы  N7 "Компоновка и размещение  компонентов в 
конструктиве печатной платы".  

В программе OrCAD Layout пунктирным прямоугольником выделяется 
область DRC Box, внутри которой по команде Auto>Design Rule Check (DRC) 
проверяется соблюдение технологических ограничений и по другим командам 
меню Auto выполняется ряд команд автотрассировки. Для перемещения этой 
области выбирается команда View>DRC Box и затем производится щелчок ле-
вой кнопки мыши. После этого область DRC Box перемещается вместе с курсо-
ром, не изменяя своих размеров. Для изменения ее размеров после выбора ко-
манды View>Zoom DRC/Route Box нажимается и удерживается левая кнопка 
мыши и затем движением курсора наносится прямоугольная область. Наиболее 
естественно, когда граница области DRC/Round Box совпадает с контуром ПП.  

Контроль позволяет обнаруживать неправильно реализованные электри-
ческие связи и нарушения заданных параметров для элементов печатного мон-
тажа. 

Результаты решения задач проектирования ПП могут быть использованы 
для формирования конструкторской  документации  (чертежи ПП) и описаний 
ПП в форматах программно-управляемого технологического  оборудования 
(фотонаборные установки, сверлильные автоматы и т.д.).  

Для изготовления технологических фотошаблонов можно использовать 
программу Gerber Tool. Формирование набора данных для этой программы ре-
комендуется выполнять следующим образом. 

Для открытия окна настройки параметров вывода Gerber выбираем меню 
“Options” и щелкаем на закладку “Post Process Settings…”. В открывшемся окне 
представлена таблица слоев, содержащая информацию о параметрах вывода. В 
первой колонке отображается расширение файлов, с которыми будут выводить-
ся данные, во второй – включен или нет слой для экспорта, в третьей – формат 
выводимых данных, в четвертой – сдвиг относительно базового слоя и, нако-
нец, в последней колонке - название соответствующего слоя.  
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Для экспорта необходимо включить следующие слои: “Top” (Верх), 
“Bottom”(Низ) , “Soldermask Top” (Верхняя маска), “Soldermask Bottom” (Ниж-
няя Маска), “Silkscreen Top” (Верхняя шелкография), “Silkscreen Bottom” 
(Нижняя шелкография) и “Drill Drawing” (Обозначение отверстий).  

Доступ к параметрам вывода соответствующего слоя открывается после 
двойного щелчка мышью на нужной строке таблицы либо через правую кнопку 
мыши и меню “Properties”. При этом мы вызываем диалог "Post Process 
Settings” (Установки вывода).  

В группе “Output ->Format” необходимо выбрать “Extended Gerber”, в 
группе “Output->Options” флажки "Create Drill Files" (Генерировать файлы 
сверловки) и "Enable for Post Processing" (Сделать доступным для вывода). 
Флажок "Overwrite Existing Files" (Перезаписывать существующие файлы) сле-
дует отмечать, если необходимо произвести экспорт в ту же директорию, в ко-
торую он производился ранее. Все остальные параметры оставьте без измене-
ния. Для запуска процедуры экспорта данных идем в меню “Auto”, там выбира-
ем пункт “Run Post Processor”.  

По окончании выводится отчет (Post Processor Report) с указанием неко-
торой статистической информации по выводимым данным, что в принципе не 
представляет особого интереса, и отчета о наличии ошибок и их количества. 
Отличием полученного на выходе пакета файлов от других является название 
файла сверловки. В OrCAD'е этот файл всегда именуется как "TRUHOLE.tap" и 
располагается в директории экспорта (по умолчанию - это директория местопо-
ложения исходного файла в формате *.max).  

В дальнейшем, полученные файлы могут быть обработаны в программах 
технологической подготовки данных для производства печатных плат (ПП), 
таких как: CAM350, CAMTASTIC, GerbTool и другие.  
 

8.2 Описание последовательности выполнения задания 
 
8.2.1 Доработать функциональную схему до уровня принципиальной. 
8.2.2 Подготовить список соединений схемы в формате Layout. 
8.2.3 Установить требуемые для работы параметры программы Layout 

командой System Settings (меню Options). 
8.2.4 Сформировать базу данных новой ПП. 
8.2.5 Сформировать Board Outline. 
8.2.6 Выполнить размещение компонентов. 
8.2.7 Оценить качество размещения. 
 
8.3 Оформление лабораторной работы 
 
Отчет по лабораторной работе должен содержать: 
- обоснование выбранной стратегии автотрассировки; 
- эскизы чертежей ПП. 
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8.4  Контрольные вопросы 
 
8.4.1 Сформулируйте содержание и цели задачи трассировки. 
8.4.2 Перечислите  формальные критерии оптимальности решения 
задачи трассировки. 
8.4.3 Перечислите основные особенности трассировки ОПП, ДПП и 

МПП. 
8.4.4 Какие математические модели монтажного пространства и электри-

ческих схем используются при автотрассировке? 
8.4.5 Каким образом задаются в среде программы  OrCAD Layout тополо-

гические свойства монтажного пространства ПП, метрические параметры эле-
ментов печатного монтажа?  

 



 45

9 Оформление конструкторской документации 
 
9.1 Рекомендации по выполнению 

 
Цель занятия - получить практические навыки по работе со средствами 

автоматизированного оформления конструкторской документации. 
Результаты решения задач проектирования ПП могут быть использованы 

для формирования конструкторской  документации  (чертежи ПП).  
Для изготовления конструкторской  документации можно использовать 

программу AutoCAD. Формирование набора данных для этой программы реко-
мендуется выполнять следующим образом. 

В среде программы OrCAD Layout формирование набора данных выпол-
няется с помощью команды File>Export>Layout to DXF. В открывшемся меню 
MAX to DXF необходимо указать Input Layout File, Output DXF File файл кон-
фигурации DXF ini File (maxdxf.ini).  

Формирование чертежей и других конструкторских документов в среде 
программы начинается с загрузки шаблона документа необходимого формата. 
Для документов формата А4 рекомендуется использовать шаблон A4 title block, 
который находится в папке \…\AutoCAD\Template.  

Загрузка данных в формате DXF выполняется по команде Вставка>Блок. 
В открывшемся меню Вставка необходимо задать имя DXF файла, установить 
флажок Однородный масштаб и задать значение масштаба Х 25. После выбора 
точки вставки фиксация изображения выполняется при нажатии левой кнопки 
мыши. Отдельные элементы изображения распределены по слоям. Это распре-
деление определяется структурой исходного Layout File (имя.мах), а также со-
держанием файла конфигурации DXF ini File.  

Используя Менеджер свойств Слоя, который активируется кнопкой Слои, 
следует установить такую комбинацию состояний атрибута Включено, чтобы 
остались видимыми только необходимые для документа слои изображения. 

На чертежах следует указать необходимые для изготовления деталей и 
справочные размеры. Размещение размерных линий выполняется автоматиче-
ски по командам в меню Размерность.  

Используя команды меню Рисование на чертеже печатной платы должны 
быть нанесены любым способом, который допускают стандарты, линии коор-
динатной сетки, надписи т.д. Для надписей рекомендуется использовать чер-
тежный шрифты Gost Type A или Gost Type A, которые можно выбрать коман-
дой Стиль текста меню Формат. Этой же командой задается высота букв,  фак-
тор ширины и угол наклона (косой угол).   

Перед печатью документа (команда Вычерчивание меню Файл) рекомен-
дуется выполнить команду Просмотр вычерчивания и, в случае необходимости, 
скорректировать масштаб изображения и его смещение относительно границ 
листа (команда Установка страницы).  

     
 
 



 46 

9.2 Оформление лабораторной работы 
 
Отчет по лабораторной работе должен содержать: 
- эскиз чертежа ПП; 
- эскиз сборочного чертежа ТЭЗ. 
 
9.3  Контрольные вопросы 
9.3.1. На какой стадии проектирования выполняется оформление конст-

рукторской документации? 
9.3.2. Каким образом в среде программы  AutoCAD формируются конст-

рукторские документы? 
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