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1 Отладка простых программ 
 
1.1 Описание работы с кратким изложением теории 

 
Цель работы: 
- освоить работу в среде системы MPLAB IDE; 
- приобрести практические навыки отладки простых программ. 
Объектом отладки в работе является программа генератора чисел. Число-

вая последовательность (в соответствии с вариантом задания) формируется на 
линиях порта PORTD.   

MPLAB IDE – это интегрированная среда разработки программ для мик-
роконтроллеров (МК) PICmicro фирмы Microchip, позволяющая писать, компи-
лировать и отлаживать программы [1]. MPLAB IDE включает несколько инст-
рументальных средств: 

- Project Manager (менеджер проекта)  необходим, чтобы создать проект и 
работать с файлами, связанными с проектом; 

- Editor (редактор) необходим для создания и редактирования исходных 
текстов программ, а также используется как окно отладчика;  

- Language Tools (языковый инструмент) – позволяет работать с кросс- ас-
семблером MPASM или кросс-компиляторами; 

- Debugger (отладчик) – совместно с редактором реализует механизмы 
управляемости и наблюдаемости процесса отладки целевых программ; 

- Execution Engines (механизм исполнения команд) – программные симу-
ляторы, позволяющие выполнять команды МК на персональном компьютере  и 
имитировать работу периферийных модулей. 

Подобно другим инструментальным средствам разработки программ 
MPLAB IDE содержит встроенный отладчик программ. Но в отличие от рези-
дентных систем в процессе отладки используется не процессор компьютера, а 
МК PICmicro или его программно-логическая модель. В системе MPLAB IDE 
реализованы следующие режимы работы отладчика:  

- MPLAB-SIM Simulator – отладка средствами симулятора, который  моде-
лирует работу процессорного ядра и периферийных модулей МК PICmicro;  

- MPLAB-ICE Emulator – отладка средствами внутрисхемного эмулятора 
(аппаратного блока для замещения МК PICmicro в реальном времени в отлажи-
ваемой системе);  

- MPLAB-ICD Debugger - отладка средствами внутрисхемного отладчика 
(аппаратного блока, позволяющего использовать встроенные в МК PICmicro 
средства отладки в реальном времени в отлаживаемой системе). 

Основное окно системы MPLAB IDE выглядит аналогично большинству 
инструментальных приложений Windows. Вверху расположена панель меню, а 
внизу строка состояния. В строке состояния отображается текущая настройка и 
состояние отладочной системы. Для разработки доступны все инструменты, в 
том числе для отладки исполняемого кода.  
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1.2 Создание нового проекта и трансляция программы 
 

В процессе разработки программы формируется проект - множество 
взаимосвязанных файлов, включая исходный текст программы <имя>.asm, за-
грузочный модуль <имя>.hex и другие файлы. Все эти файлы удобно хранить в 
отдельной папке. Взаимосвязи файлов содержатся в корневом файле проекта.  

В папке PIC создайте свою рабочую папку, а в ней папку lr1. Скопируйте 
в нее подготовленный файл с исходным текстом программы lr1.asm. Создайте 
новый проект, для этого выберите команду Project > Project Wizard и последо-
вательно выполните действия: 

- задайте тип микроконтроллера PIC16F877;  
- задайте транслятор Microchip MPASM Toolsuite; 
- задайте имя проекта lr1 и папку для нового проекта; 
- включите в проект исходный текст программы lr1.asm. 
Откройте окно с исходным текстом программы, для этого в окне менед-

жера проекта lr1.mcw дважды щелкните по ярлыку lr1.asm в папке Source Files 
или выполните команду File>Open.  

Выполните трансляцию программы (команда Project>Make). На закладке 
Build в окне Output будет приведена командная строка, посланная ассемблеру, 
сообщения об ошибках или успешном завершении трансляции.  

Если программа содержала синтаксические и другие формальные ошиб-
ки, в окне будет выведен список сообщений об ошибках (ERROR). Если дваж-
ды щелкнуть мышкой на сообщении об ошибке, то курсор автоматически пе-
рейдет к соответствующему оператору в исходном тексте. Если в программе 
нет подобных ошибок, ассемблер выдаст сообщение BUILD SUCCEEDED. Это 
означает, что получен загрузочный модуль программы, готовый для выполне-
ния микроконтроллером. Но это не означает, что программа не содержит логи-
ческих ошибок, и будет работать правильно. Проверку работы программы, по-
иск и исправление возможных ошибок выполняют в ходе отладки. 

 
1.3 Отладка программы 

 
В данной лабораторной работе предусмотрено выполнение только авто-

номной отладки программы на программно-логической модели МК. Активиро-
вать инструмент MPLAB-SIM Simulator можно командой Debugger>Select 
Tool>MPLAB SIM. 

Существуют различные методы тестирования программ, направленные на 
проверку их правильности и выявление возможных ошибок. Но практически 
все они основаны на отслеживании выполнения программы и сравнении с ожи-
даемым ходом выполнения. Для отладки программ обычно применяют два ре-
жима: 

- пошаговая отладка;  
- выполнение программы (прогон) до точки останова.  
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При пошаговой отладке выполняется один оператор программы, и затем 
контролируются те переменные, на которые должен воздействовать данный 
оператор. 

Отдельный участок программы можно выполнить в режиме прогона. 
Точку останова устанавливают на операторе, при выполнении которого необ-
ходимо проверить значения переменных или просто проконтролировать, пере-
даётся ли управление данному оператору. 

Для отслеживания содержимого ограниченного набора ячеек памяти 
удобно использовать смотровое окно. Чтобы создать смотровое окно выполни-
те команду View> Watch. В верхней части окна Watch находятся прокручивае-
мые списки регистров специальных функций (SFR) и идентификаторов, исполь-
зуемых в программе (Symbol). Из левого списка выберите ячейку PORTD, до-
бавьте в окно наблюдения нажатием кнопки Add SFR. Из правого списка выбе-
рите ячейку Cnt, добавьте в окно наблюдения нажатием кнопки Add Symbol.  

Инициализируйте МК нажатием кнопки Reset. Программный счетчик бу-
дет сброшен в ноль. Средствами символьного отладчика строка исходного кода, 
соответствующая этому адресу, отмечена указателем (зеленой стрелкой). В 
строке состояния MPLAB IDE отображаются: 

- режим работы отладчика (MPLAB SIM); 
- тип МК (PIC16F877); 
- содержимое программного счетчика PC; 
- содержимое аккумулятора W; 
- состояние флагов Z dc c (заглавной буквой – установлен, строчной – 

сброшен); 
- тактовая частота МК (20 MHz); 
- активный банк памяти данных (bank 0). 
Нажмите кнопку Step Into. Будет выполнена первая команда программы. 

Программный счетчик будет показывать PC:0x01, указатель переместится на 
следующую исполняемую команду. Для пошагового выполнения можно также 
использовать функциональную клавишу <F7>. Нажимайте клавишу <F7> не-
сколько раз и наблюдайте, как перемещается по тексту  указатель, изменяются 
показания программного счетчика и значения переменных в смотровом окне.  

Для регистрации значений переменных в процессе прогона программы 
можно использовать память трассы. Установите курсор на строке с оператором 
goto Loop. Нажмите правую кнопку мыши и в появившемся меню выберите оп-
цию Set Breakpoint (точка останова). Слева от этой строки появится символ “B” 
красного цвета, сигнализируя, что сразу перед исполнением команды в этой 
строке выполнение программы остановится. 

Продолжите выполнение программы в режиме прогона командой Run или 
клавишей <F9>. При достижении точки останова симулятор остановится на вы-
деленном операторе (но эта команда не выполнится).  

Открыть окно памяти трассы можно командой View>Simulator Trace . 
Каждая запись памяти трассы содержит:  

- адрес команды (Addr); 
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- код команды (Op); 
- метку (Label); 
- дизассемблерное представление команды (Instruction); 
- адрес и содержимое ячейки источника (SA и SD); 
- адрес и содержимое ячейки приемника (DA и DD); 
- текущее время в циклах (Cycles). 
Содержимое буфера трассировки можно сохранить в файле командой 

Output to File, очистить буфер трассировки можно командой Clear Trace Buffer 
(панель команд открывается правой кнопкой мыши). 

Если нажать клавишу <F9> еще раз, симуляция программы продолжится 
до следующего достижения точки останова. Разумеется, когда программа вы-
полняется и не достигла точки останова, ее можно остановить командой Halt 
или нажатием клавиши <F5>.  

По содержимому окна Watch и буфера трассировки определите коррект-
ность выполнения программы. При выявлении несоответствия хода выполне-
ния программы ожидаемому, необходимо локализовать ошибку в программе.  
Для этого необходимо: 

- определить шаг (и соответствующий оператор программы), начиная с 
которого выполнение программы отклоняется от ожидаемого; 

- проанализировать причину этого отклонения; 
- исправить ошибку в исходном тексте; 
- выполнить трансляцию программы. 
При последующем тестировании необходимо убедиться в корректности 

выполнения программы. После выполнения работы закройте проект командой 
Project>Close. 

 
1.4 Содержание отчета 

 
Отчет должен содержать:  
- схему алгоритма программы; 
- исходный текст программы; 
- трассу программы;  
- выводы о корректности программы. 
 

1.5 Контрольные  вопросы 
 
1.5.1 Перечислите основные инструментальные средства и режимы работы 

отладчика системы MPLAB IDE.  
1.5.2 Перечислите основные режимы отладки программ в среде MPLAB IDE? 
1.5.3 Поясните по схеме алгоритма работу программы. 
1.5.4 Поясните содержание трассы программы? 
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2 Трансляция и отладка программ сложной структуры 
 
2.1 Описание работы с кратким изложением теории  
 
Цель работы - получить практические навыки выполнения трансляции и 

автономной отладки в среде MPLAB IDE программ сложной структуры. 
Содержанием работы является трансляция и автономная отладка про-

граммы сложной структуры для МК типа PIC16F877. Программа имеет слож-
ную структуру и состоит из основной программы и вызываемой подпрограммы 
умножения восьмиразрядных чисел. 

Исследуются два варианта трансляции исходных текстов одной и той же 
программы сложной структуры [2]:  

- для прямой генерации абсолютного кода, который может быть загружен 
непосредственно в память программ микроконтроллера; 

- для генерации объектных файлов, которые необходимо связывать при 
помощи редактора связей MPLINK. 
 

2.2 Описание последовательности выполнения 
 
2.2.1 Трансляция и отладка программы из одного исходного файла 
 
В своей рабочей папке создайте папку lr2_1. Скопируйте в нее подготов-

ленный файл с исходным текстом программы lr2_1.asm. Создайте новый проект 
с помощью мастера Project > Project Wizard. Задайте имя проекта lr2_1, вклю-
чите в проект исходный текст программы lr2_1.asm. 

Откройте окно с исходным текстом программы. Выполните трансляцию 
программы (команда Project>Make). Если программа содержала синтаксиче-
ские и другие формальные ошибки, исправьте их и повторите трансляцию.  

В результате трансляции формируются загрузочный модуль программы, 
листинг трансляции lr2_1.lst. Проанализируйте листинг программы, определите 
объем полученного кода и число используемых ячеек памяти данных. Включи-
те листинг в отчет. 

Проверку работы программы, поиск и исправление возможных ошибок 
выполняют в ходе отладки. Активируйте инструмент MPLAB-SIM Simulator ко-
мандой Debugger> Select Tool>MPLAB SIM. Создайте смотровое окно коман-
дой View> Watch. Включите в смотровое окно основные ячейки: 

- mulcnd;  
- mulplr;  
- H_byte;  
- L_byte;  
- count;  
- H_sum;  
- L_sum. 
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Откройте окно стека командой View>Hardware Stack. Выполните провер-
ку работы программы в пошаговом режиме или режиме прогона с остановом. В 
последнем случае определите операторы для точек останова. При отладке про-
граммы проследите за изменениями ячеек памяти данных, передачей управле-
ния и содержимым стека. Если ход и результаты выполнения программы отли-
чаются от ожидаемых, необходимо локализовать и устранить ошибки.  

Закройте проект командой Project>Close. 
 
2.2.2 Трансляция и отладка программы из нескольких исходными файлов 
 
В своей рабочей папке создайте папку lr2_2. Скопируйте в нее подготов-

ленный файл с исходным текстом программы lr2_2.asm и файл подпрограммы 
умножения mul8x8.asm. Создайте новый проект с помощью мастера Project > 
Project Wizard. Задайте имя проекта lr2_2, включите в проект файлы исходных 
текстов программы lr2_2.asm и подпрограммы mul8x8.asm. 

Откройте окна с исходными текстами программы. Выполните трансля-
цию программы (команда Project>Make). Если программа содержала синтакси-
ческие и другие формальные ошибки, исправьте их и повторите трансляцию.  

В результате трансляции формируются объектные модули и листинги 
трансляции lr2_2.lst и mul8x8. lst. В результате работы линкера формируется за-
грузочный модуль и карта памяти lr2_2.map. Проанализируйте листинги и кар-
ту памяти программы, определите объем полученного кода и число используе-
мых ячеек памяти данных. Включите листинги и карту памяти в отчет. 

Выполните проверку работы программы, поиск и исправление возмож-
ных ошибок. Закройте проект командой Project>Close. 

 
2.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- схему алгоритма; 
- листинги трансляции, карту памяти; 
- результаты проверки работы программы, выводы. 
 
2.4 Контрольные  вопросы 
 
2.4.1 Поясните особенности выполнения программ сложной структуры.  
2.4.2 Как может выполняться в среде MPLAB IDE трансляция программ 

сложной структуры? 
2.4.3 Перечислите основные отличия правил формирования исходных 

текстов программ на языке ассемблера при трансляции в абсолютный или объ-
ектный код? 

2.4.4 Поясните назначение стека. 
2.4.5 Поясните по схеме алгоритма работу программы. 
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3 Отладка программы формирования интервалов времени 
 
3.1 Описание работы с кратким изложением теории  

 
Цель работы - получить практические навыки выполнения автономной и 

комплексной отладки программ, использующих таймер. 
Содержанием работы является автономная и комплексная отладка про-

граммы для МК типа PIC16F877 [3] с использованием  интегрированной систе-
мы MPLAB IDE и внутрисхемного отладчика MICD2. Объектом отладки в ра-
боте является программа формирования интервалов времени, через которые 
происходит переключение выходной линии RD0 порта POPTD (в соответствии 
с вариантом задания). Для отсчета интервалов времени используется встроен-
ный таймер TMR0.  

При выполнении автономной отладки программу выполняет симулятор, 
взаимодействующий с отладчиком системы MPLAB IDE.  При выполнении 
комплексной отладки программу выполняет реальный МК, который может 
быть установлен в различных устройствах. На лабораторном занятии ком-
плексная отладка программы выполняется на отладочном стенде. Для обеспе-
чения взаимодействия МК с отладчиком системы MPLAB IDE необходимы 
специальные аппаратные средства поддержки, в качестве которых используется 
внутрисхемный отладчик MPLAB ICD2 [4] или его аналог MICD2.  

Схема подключения модуля MICD2 к компьютеру и отлаживаемому мик-
ропроцессорному устройству (МПУ) - отладочному стенду приведена на ри-
сунке 3.1. Питание отлаживаемого устройства будет осуществляться от модуля 
MICD2, который, в свою очередь, получает питание от блока питания (AC-DC 
адаптера 9 В). Отлаживаемое устройство и модуль MICD2 имеют открытые то-
коведущие части, находящие под напряжением не более 12 В. Важно помнить, 
что при коммутации (подключении или отключении) устройств на линиях связи 
могут кратковременно формироваться броски напряжения, многократно пре-
вышающие номинальные значения уровней напряжения. Поэтому при любых 
коммутациях питание модуля MICD2 должно быть отключено.  

 

 
Рисунок 3.1 

 
Директива __CONFIG в программе позволяет задать необходимые значе-

ния разрядов слова конфигурации PIC16F877 (адрес H’2007’). После трансля-
ции их значения можно наблюдать и редактировать  в окне Configure> 
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Configuration Bits. Требуемые значения разрядов для обеспечения возможности 
отладки с помощью отладчика MICD2 приведены в таблице 3.1. 

 
 Таблица 3.1 - Разряды слова конфигурации  

Пункт Опция 
Oscillator Кварцевый резонатор (XT) 
Watchdog 

Timer 
Сторожевой таймер (WDT) должен быть выключен (Off) 

Power Up Timer Таймер включения (PWRT) должен быть включен (On). 
Brown Out 

Detect 
Детектор дрожания напряжения питания (BOD) должен быть 
выключен (Off) 

Low Voltage 
Program 

Низковольтное программирование должно быть 
запрещено (Disabled) 

Flash Memory 
Write 

Запись Flash Memory должна быть разрешена (Enabled) 

Data EE  
Read Protect 

Защита данных EEPROM должна быть выключена (Off) 

Code Protect Защита кода программы должна быть выключена (Off) 
 
3.2 Описание последовательности выполнения 

 
3.2.1 В папке PIC создайте свою рабочую папку. Скопируйте в нее подго-

товленный файл с исходным текстом программы lr3.asm. Создайте новый про-
ект с помощью мастера Project>Project Wizard. Задайте имя проекта lr3, вклю-
чите в проект исходный текст программы lr3.asm. 

Откройте окно с исходным текстом программы. Выполните трансляцию 
программы (команда Project>Make). Если программа содержала синтаксиче-
ские и другие формальные ошибки, исправьте их и повторите трансляцию.  

3.2.2  Активируйте отладчик MPLAB IDE для работы с симулятором (ко-
манда Debugger> Select Tool>MPLAB SIM). Настройте симулятор для выполне-
ния автономной отладки данного приложения (команда Debugger>Setting). В 
окне Simulator Setting на закладке Osc/Trace задайте значение тактовой частоты 
Processor Frequency 3.6864 MHz.  

Создайте окно наблюдения интересующих ячеек памяти данных (команда 
View>Watch). В левом окне выберите PORTD и нажмите кнопку Add SFR. В 
правом окне выберите Count05s и нажмите кнопку Add Symbol.  

Контролировать текущие значения ячеек можно в окне наблюдения. Вы-
полните команду View> Watch, чтобы создать окно наблюдения интересующих 
ячеек памяти данных: PORTD, Count05s. 

Контролировать текущее время выполнения программы, а также время 
выполнения отдельных ее участков, измерять интервалы времени между раз-
личными событиями можно с помощью секундомера. Откройте окно секундо-
мера Debugger>Stopwatch. В окне секундомера можно увидеть текущий номер 
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цикла, текущее время выполнения программы и тактовую частоту микрокон-
троллера.  

Установите точки останова на оператора вызова подпрограммы формиро-
вания временного интервала (call Dly) и возврата из подпрограммы (return) . 

Выполните сброс МК (Debugger>Reset>Processor Reset), а затем активи-
руйте выполнение программы в режиме прогона (Debugger>Run). При останове 
программы в первой точке сбросьте показания секундомера в окне StopWatch 
кнопкой Zero. Активируйте дальнейшее выполнение программы в режиме про-
гона (Debugger>Run). При останове программы по адресу команды return по 
показаниям секундомера контролируйте время выполнения подпрограммы Dly. 
При отклонении измеренного значения от расчетного проверьте правильность 
настройки таймера TMR0 и выполните отладку подпрограммы  Dly. Измерен-
ное значение временной задержки занесите в отчет. 

При отладке программы в среде симулятора следует учитывать, что ско-
рость моделирования зависит от производительности компьютера.  

3.2.3 Подключите отладчик MICD2 к стенду и персональному компьюте-
ру. Только после этого  можно подключить к отладчику MICD2 источник 
питания. Нарушение этого требования может привести к выходу из строя пор-
тов компьютера и отладчика MICD2! 

Активируйте отладчик MPLAB IDE для работы с MICD2 (команда 
Debugger>Select Tool>MPLAB ICD2). Настроить отладчик MPLAB IDE для вы-
полнения комплексной отладки данного приложения можно с помощью инст-
румента MPLAB ICD2 Setup Wizard. Для связи с отладчиком MICD2 выберите 
порт Com1 и скорость обмена Baud Rate 57600. Далее задайте способ подклю-
чения источника питания через отладчик (Power target from the MPLAB ICD2). 
Автоматическое установление связи с отладчиком MICD2 необходимо запре-
тить (снять флажок на опции MPLAB IDE automatically connects to MPLAB 
ICD2). Автоматическую загрузку программного обеспечения отладчика необ-
ходимо разрешить (установить флажок на опции MPLAB IDE automatically 
downloads the required operating system). Далее необходимо принять во внима-
ние сообщение, что для работы с отладчиком MPLAB ICD2 буферы FIFO Com-
порта должны быть отключены.  

Установите связь с отладчиком MICD2 командой Debugger>Connect. Ес-
ли в окне Output на закладке MPLAB ICD2 появится сообщение об ошибке, про-
верьте подключение источника питания, разъемы и соединительные кабели.  

После установления связи, загрузки программного обеспечения отладчи-
ка (Operating System) и самотестирования можно приступить к загрузке прило-
жения в целевой микроконтроллер отладочного стенда по команде Debugger> 
Program. При успешном завершении программирования МК в окне Output на 
закладке MPLAB ICD2 появится сообщение:  
Connecting to debug executive 
...Programming succeeded 
дата, время 
MPLAB ICD 2 Ready. 
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MPLAB-ICD2 позволяет МК PIC16F877 выполнять программу в режиме 
прогона (реального времени), пошаговом режиме или анимации. Начните с ре-
жима выполнения в реальном времени. Нажмите кнопку панели Run или выбе-
рите команду Debugger>Run. С помощью часов оцените длительность интерва-
лов времени между моментами переключения светодиода, подключенного к 
линии 0 порта PORTD. Сравните с расчетными значениями. Нажмите кнопку 
панели Halt или выберите команду Debug>Halt, чтобы остановить выполнение 
программы.  

Установите точку останова на команде call  Dly. Запускайте программу на 
выполнение в режиме прогона до полного выполнения одного цикла основной 
программы. При достижении точки останова регистрируйте в отчете значение 
параметра, передаваемого подпрограмме Dly - содержимое аккумулятора.  

Отключите отладчик системы MPLAB IDE командой Debugger> Select 
Tool>None. Отключите питание MICD2. После этого можно отключить 
кабель от COM-порта компьютера. Закройте проект командой Project>Close. 

 
3.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- схему алгоритма программы; 
- исходный текст программы; 
- результаты отслеживания выполнения программы при автономной и ком-

плексной отладке; 
- расчетные и измеренные значения задержек; 
- выводы. 
 
3.4 Контрольные  вопросы 
 
3.4.1 Поясните, каким образом можно настроить таймер TMR0 на тре-

буемый режим работы. 
3.4.2 Поясните, каким образом выполняется расчет задержек. 
3.4.3 Поясните по схеме алгоритма работу программы. 
3.4.4 Поясните назначение слова конфигурации МК, его отдельных раз-

рядов. Каким образом можно задать требуемые значения разрядов? 
3.4.5 Перечислите основные режимы работы отладчика системы MPLAB 

IDE. Как выполняется настройка среды MPLAB IDE на требуемый режим от-
ладки? 

3.4.6 Каким образом можно оценить длительность формируемых времен-
ных интервалов с использованием симулятора? 

3.4.7 Каким образом можно отслеживать выполнение программы с ис-
пользованием внутрисхемного отладчика MICD2? 
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4 Отладка программы дискретного ввода-вывода 
 
4.1 Описание работы с кратким изложением теории  
 
Цель работы - получить практические навыки выполнения автономной и 

комплексной отладки программ дискретного ввода-вывода в среде MPLAB IDE. 
Содержанием работы является отладка программы для МК типа 

PIC16F877, которая анализирует состояние кнопок, подключенных к линиям 
порта RB1 и RB2. Нажатие с последующим отпусканием кнопок RB1 и RB2 вы-
зывает разнонаправленную модификацию содержимого ячейки Cnt (в соответ-
ствии с вариантом задания), которое отображается на светоизлучающих диодах, 
подключенных к линиям порта PORTD. Активному (нажатому) состоянию 
кнопки соответствует низкий потенциал на линии порта PORTB. Пассивному 
(отжатому) состоянию кнопки соответствует высокий потенциал, который 
обеспечивается встроенными подтягивающими резисторами. 

 
4.2 Описание последовательности выполнения 
 
4.2.1 В папке PIC создайте свою рабочую папку. Скопируйте в нее подго-

товленный файл с исходным текстом программы lr4.asm. Создайте новый про-
ект с помощью мастера Project>Project Wizard. Задайте имя проекта lr4, вклю-
чите в проект исходный текст программы lr4.asm. 

Откройте окно с исходным текстом программы. При выполнении авто-
номной отладки целесообразно отключить функции подавления дребезга кон-
тактов кнопок. Для этого достаточно закомментировать операторы вызова под-
программы задержки D15ms. Выполните трансляцию программы (команда 
Project>Make). Если программа содержала синтаксические и другие формаль-
ные ошибки, исправьте их и повторите трансляцию.  

4.2.2  Активируйте отладчик MPLAB IDE для работы с симулятором (ко-
манда Debugger>Select Tool>MPLAB SIM). Настройте симулятор для выполне-
ния автономной отладки данного приложения (команда Debugger>Setting). В 
окне Simulator Setting на закладке Osc/Trace задайте значение тактовой частоты 
Processor Frequency 3.6864 MHz.  

Выполните команду View> Watch, чтобы создать окно наблюдения инте-
ресующих ячеек памяти данных: PORTB, PORTD, Cnt. 

Для автономной отладки программы необходимо иметь средства имита-
ции нажатия кнопок. Для этих целей можно использовать асинхронные стиму-
лы. Чтобы создать асинхронный стимул, выберите пункт меню Debugger> 
Stimulus>New Workbook для открытия диалогового окна настройки стимулов. В 
открывшемся окне Stimulus на закладке Asynch содержится таблица, каждая 
строка которой позволяет задать атрибуты одного стимула. Установите курсор 
на первой строке в столбце Pin/SFR и задайте линию порта ввода RB1. На вто-
рой строке в столбце Pin/SFR и задайте линию порта ввода RB2. В столбце 
Action выберите значение Set High (высокий уровень) для обоих стимулов. Эти 
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значения будут имитировать исходное воздействие подтягивающих резисторов. 
В двух следующих строках таблицы создайте стимулы для RB1 и RB2 для ими-
тации воздействия кнопок. Для этого в столбце Action выберите значение Pulse 
Low (импульс низкого потенциала), а в столбце Width значение длительности 
импульса в единицах времени, указанных в столбце Units. Длительность этих 
импульсов в реальном устройстве определяется временем нажатия кнопки и со-
ставляет доли секунды. При моделировании целесообразно задать существенно 
меньшие значения, чтобы сократить время моделирования. Вполне достаточно 
установить 100 cyc. 

4.2.3  Необходимо выполнить тестирование программы. Сначала следует 
задать исходные (пассивные) значения разрядов RB1=1 и RB2=1. Произвольно 
изменить содержимое PORTB не удастся, поэтому произведите сброс МК 
(Debugger> Reset), затем нажмите кнопку Fire стимула RB1 и кнопку Fire сти-
мула RB2 типа Set High, выполните одну команду программы (Debugger>Step 
Into). Проконтролируйте установку значений разрядов 1 и 2 порта PORTB в ок-
не наблюдения.  

Проверку работы программы удобно  выполнять в режиме анимации (бы-
строго пошагового режима), который активируется командой  Debugger 
>Animate.  В этом режиме после выполнения очередной команды обновляется 
содержимое всех открытых окон системы MPLAB IDE и только затем управле-
ние передается следующей команде программы. 

Нажмите кнопку Fire стимула RB2 типа Pulse Low на панели контроллера 
стимулов. Проследите за изменением соответствующего разряда PORTB в окне 
наблюдения. Убедитесь, что «нажатие» кнопки вызывает необходимую моди-
фикацию переменной Cnt. Повторите эту проверку необходимое число раз. Вы-
полните аналогичные проверки для стимула RB1 типа Pulse Low. Занесите в от-
чет формируемую последовательность значений переменной Cnt. Остановите 
процесс выполнения программы нажатием кнопки Halt.  

4.2.4  Восстановите операторы вызова подпрограммы задержки D15ms в 
исходном тексте программы. Выполните трансляцию программы. Подключите 
отладчик MICD2 к стенду и персональному компьютеру. Только после этого  
можно подключить к отладчику MICD2 источник питания. Нарушение 
этого требования может привести к выходу из строя портов компьютера и от-
ладчика MICD2! 

Активируйте отладчик MPLAB IDE для работы с MICD2 (команда 
Debugger>Select Tool>MPLAB ICD2). С помощью инструмента MPLAB ICD2 
Setup Wizard настройте отладчик MPLAB IDE для выполнения комплексной от-
ладки данного приложения. Установите связь с отладчиком MICD2 командой 
Debugger>Connect. Если в окне Output на закладке MPLAB ICD2 появится со-
общение об ошибке, проверьте подключение источника питания, разъемы и со-
единительные кабели.  

После установления связи, загрузки программного обеспечения отладчи-
ка (Operating System) и самотестирования выполните загрузку целевого прило-
жения в микроконтроллер отладочного стенда по команде Debugger>Program.  
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Нажмите кнопку панели Run или выберите команду Debugger>Run. По 
состоянию линейки светодиодов, подключенных к выводам PORTD, проверьте 
реакцию МК на нажатие кнопок «+1» и «-1». Сравните с заданным поведением. 
Нажмите кнопку панели Halt или выберите команду Debugger>Halt, чтобы ос-
тановить выполнение программы. Сбросьте МК, выбрав  Debugger> Reset> 
Processor Reset.  

Если результаты проверки Вас разочаровали, то в данном случае, вероят-
нее всего, причина в настройке портов или дребезге контактов. Проверьте пра-
вильность управляющих слов, загруженных в регистры TRISB, TRISD, 
OPTION_REG. Проверьте правильность реализации функции подавления дре-
безге контактов. После исправления ошибок и трансляции программы, повто-
рите загрузку целевого приложения в МК и тестирование программы. 

В случае успеха отключите отладчик системы MPLAB IDE командой 
Debugger> Select Tool>None. Отключите питание MICD2. После этого 
можно отключить кабель от Com-порта компьютера. Закройте проект ко-
мандой Project>Close. В противном случае необходимо локализовать и устра-
нить ошибки в программе. 

 
4.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- схему алгоритма программы; 
- исходный текст программы; 
- граф состояний реализованного МПУ; 
- выводы. 
 
4.4 Контрольные  вопросы 
 
4.4.1 Поясните по схеме алгоритма работу программы. 
4.4.2 Как выполняется автономная отладка программ, выполняющих оп-

рос кнопок, с использованием симулятора? 
4.4.3 Как в среде симулятора можно имитировать изменения внешних 

сигналов на линиях портов ввода МК? 
4.4.4 Каким образом выполняется программное подавление «дребезга 

контактов»? 
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5 Отладка программы аналогового ввода 
 
5.1 Описание работы с кратким изложением теории  
 
Цель работы - получить практические навыки выполнения автономной и 

комплексной отладки в среде MPLAB IDE программы аналогового ввода. 
Объектом отладки в работе является программа, которая выполняет за-

пуск модуля АЦП, обрабатывает результаты преобразования и выводит их в 
PORTD на индикаторы.  

 
5.2 Описание последовательности выполнения 
 
5.2.1 В папке PIC создайте свою рабочую папку. Скопируйте в нее подго-

товленный файл с исходным текстом программы lr5.asm. Создайте новый про-
ект с помощью мастера Project>Project Wizard. Задайте имя проекта lr5, вклю-
чите в проект исходный текст программы lr5.asm. 

Откройте окно с исходным текстом программы. Выполните трансляцию 
программы (команда Project>Make). Если программа содержала синтаксиче-
ские и другие формальные ошибки, исправьте их и повторите трансляцию.  

5.2.2 Проверку работы программы, поиск и исправление возможных 
ошибок выполняют в ходе отладки. Активируйте инструмент MPLAB-SIM 
Simulator командой Debugger>Select Tool>MPLAB SIM. Настройте симулятор 
для выполнения автономной отладки данного приложения (команда Debugger> 
Setting). В окне Simulator Setting на закладке Osc/Trace задайте значение такто-
вой частоты Processor Frequency 3.6864 MHz.  

5.2.3 Сформируйте удобную среду для отладки программы. Для автоном-
ной отладки программы необходимо иметь средства имитации аналого-
цифрового преобразования. Для этих целей можно использовать стимулы реги-
стра типа Register Injection. Текстовый файл стимула регистра состоит из ко-
лонки значений, которые будут поочередно передаваться паре регистров 
ADRESH:ADRESL с учетом заданного выравнивания, когда аналого-цифровое 
преобразование будет выполнено.  

Создайте новый текстовый файл - File > New File. В безымянном окне в 
одну колонку введите список из восьми 16-ричных значений результатов 10-
разрядного аналого-цифрового преобразования, которые Вы хотите назначить 
регистрам ADRESH:ADRESL. Подберите эти значения, учитывая возможность 
контроля обработки результатов аналого-цифрового преобразования програм-
мой. Сохраните созданный файл - File > Save As… Выберите директорию, в ко-
торой хотите сохранить файл, введите имя файла с расширением txt. 

Выберите пункт меню Debugger>Stimulus>New Workbook для открытия 
диалогового окна настройки стимула регистра. В открывшемся окне выберите 
закладку Register Injection. В указанных столбцах задайте значения: 

- Reg/Var -  ADRESL; 
- Trigger – Demand; 
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- Data Filename – имя файла стимула; 
- Wrap – Yes; 
- Format - Hex. 
Нажмите кнопку Apply , затем Save  – сохраните стимул регистра. 
Контролировать текущие значения сигналов можно в окне наблюдения. 

Выполните команду View> Watch, чтобы создать окно наблюдения интересую-
щих ячеек памяти данных: ADRESH, ADRESL, PORTD. 

Чтобы получить информацию об изменениях сигналов на выводах МК 
можно использовать логический анализатор отладчика системы MPLAB IDE. 
Запуск логического анализатора выполняется по условию совпадения про-
граммного счетчика с заданным значением (адресом).  

5.2.4 Выполните тестирование программы, используя подготовленные 
стимулы. В соответствии с планом тестирования при выполнении программы 
должно произойти 8 запусков модуля АЦП. Это значит, что необходимо вы-
полнить 4 полных цикла программы. Чтобы наблюдать в окне логического ана-
лизатора последний результат, необходимо выполнить дополнительный цикл. 

Наиболее просто это обеспечить, используя сложные условия останова 
отладчика системы MPLAB IDE. Выполните команду Debugger>Complex 
Breakpoints. В открывшемся окне Simulator Complex Breakpoints нажмите кноп-
ку Add Breakpoint. В окне Set Breakpoint на закладке Program Memory  необхо-
димо в окне Address задать метку точки останова – вход в подпрограмму обра-
ботки прерывания. В окне Pass Count выберите условие Event must occur Count 
times,  в окне Count задайте число событий до останова программы. 

Откройте окно логического анализатора командой View>Logic Analyzer, 
нажмите кнопку Channals и в открывшемся окне Configure Channals нажмите 
кнопку Configure Bus(s). В открывшемся окне Configure Bus нажмите кнопку 
New Bus, в окне Bus Name  задайте имя группы (шины) – PORTD, выберите 
сигналы на линиях RD0 - RD7, подтвердите выбор нажатием кнопки OK. В ок-
не Configure Channals выберите группу PORTD, подтвердите выбор нажатием 
кнопки OK. Установить переключатель Trigger Position на Start. 

Запустите выполнение программы в автоматическом режиме. После оста-
нова программы, используя окно логического анализатора, исследуйте времен-
ные диаграммы зарегистрированных сигналов. Убедитесь, что смена значений 
выходных сигналов на линиях PORTD происходит в соответствии с планом 
тестирования. Зарегистрированные временные диаграммы для рассматриваемо-
го примера приведены на рисунке 5.1. 

 

 
 

При оценке правильности полученных результатов следует учитывать, 
что выравнивание результата аналого-цифрового преобразования и отбрасыва-
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ние двух младших разрядов эквивалентно делению заданного в файле стимула 
значения на 4.  

Установите точки останова на операторах выбора аналоговых каналов и 
операторах запуска преобразования. Используя секундомер Debugger> 
Stopwatch, оцените интервалы времени, необходимые для нормальной работы 
модуля АЦП, а также период дискретизации аналоговых сигналов. В случае не-
обходимости скорректируйте длительности задержек.  

5.2.5 Подключите отладчик MICD2 к стенду и персональному компьюте-
ру. Только после этого  можно подключить к отладчику MICD2 источник 
питания. Нарушение этого требования может привести к выходу из строя пор-
тов компьютера и отладчика MICD2! 

Активируйте отладчик MPLAB IDE для работы с MICD2 (команда 
Debugger>Select Tool>MPLAB ICD2). С помощью инструмента MPLAB ICD2 
Setup Wizard настройте отладчик MPLAB IDE для выполнения комплексной от-
ладки данного приложения. Установите связь с отладчиком MICD2 командой 
Debugger>Connect. Если в окне Output на закладке MPLAB ICD2 появится со-
общение об ошибке, проверьте подключение источника питания, разъемы и со-
единительные кабели.  

После установления связи, загрузки программного обеспечения отладчи-
ка (Operating System) и самотестирования выполните загрузку целевого прило-
жения в микроконтроллер отладочного стенда по команде Debugger>Program.  
 Активируйте выполнение программы в режиме реального времени. С по-
мощью потенциометров изменяйте значения входных напряжений и фиксируй-
те результат преобразования на светодиодных индикаторах. Проконтролируйте 
правильность отображения информации. Результаты занесите в отчет. 

Отключите отладчик системы MPLAB IDE командой Debugger>Select 
Tool>None. Отключите питание MICD2. После этого можно отключить 
кабель от COM-порта компьютера. Закройте проект командой Project>Close. 

 
5.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- схему алгоритма и исходный текст программы; 
- результаты тестирования программы (временные диаграммы, значения 

временных интервалов); 
- выводы. 
 
5.4 Контрольные  вопросы 
 
5.4.1 Поясните по схеме алгоритма работу программы. 
5.4.2 Как при автономной отладке можно проконтролировать коррект-

ность взаимодействия с модулем АЦП? 
5.4.3 Как в среде симулятора можно имитировать выполнение аналого-

цифрового преобразования? 
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6 Отладка программы вывода символьной информации 
 
6.1 Описание работы с кратким изложением теории  
 
Цель работы - получить практические навыки выполнения автономной и 

комплексной отладки программы вывода символьной информации. 
Объектом отладки в работе является программа, выполняющая запуск 

модуля АЦП, получение результатов преобразования, их обработку и вывод на 
7-сегментные индикаторы в заданном формате. Для управления индикаторами 
в отладочном стенде применен специализированный контроллер MC14489BP. 
Эта микросхема обеспечивает вывод информации на 7- сегментные индикато-
ры в режиме динамического управления.  

Информация от МК к специализированному контроллеру MC14489BP 
передается по последовательному синхронному интерфейсу, состоящему из 
трех линий: 

- RE1 (DATA IN) – данные; 
- RE0 (Clk) - синхроимпульсы; 
- RB3 (-CS) – выборка кристалла. 
Подпрограмма Dysplay обеспечивает формирование на линиях RE1, RE0, 

RB3 значений сигналов, необходимых для передачи информации. Поэтому 
объективный контроль работы этой подпрограммы должен выполняться путем 
проверки корректности формируемых последовательностей наборов этих сиг-
налов. При выполнении автономной отладки для этой цели целесообразно ис-
пользовать инструмент системы MPLAB IDE – логический анализатор. Логи-
ческий анализатор использует информацию, формируемую в буфере трассы 
программ, и может ее интерпретировать в форме временных диаграмм сигна-
лов на внешних выводах МК. Основное внимание в ниже следующем описании 
последовательности выполнения работы уделяется тестированию подпрограм-
мы Dysplay. Контроль корректности других функций программы может быть 
выполнен при использовании приемов и инструментов, которые неоднократно 
применялись в лабораторных работах №1 – 5.  

  
6.2 Описание последовательности выполнения 
 
6.2.1 В папке PIC создайте свою рабочую папку. Скопируйте в нее подго-

товленный файл с исходным текстом программы lr6.asm. Создайте новый про-
ект с помощью мастера Project>Project Wizard. Задайте имя проекта lr6, вклю-
чите в проект исходный текст программы lr6.asm. 

Откройте окно с исходным текстом программы. Выполните трансляцию 
программы (команда Project>Make). Если программа содержала синтаксиче-
ские и другие формальные ошибки, исправьте их и повторите трансляцию.  

6.2.2 Необходимо убедиться в правильности работы программы. Чтобы 
получить информацию об изменениях сигналов на выводах МК можно исполь-
зовать логический анализатор отладчика системы MPLAB IDE. Запуск логиче-
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ского анализатора выполняется по условию совпадения программного счетчика 
с заданным значением (адресом).  

Тестирование подпрограммы Display: 
- создайте окно наблюдения и включите в него ячейки Fig2, Fig1, Fig0; 
- откройте окно логического анализатора командой View>Logic Analyzer, 

нажмите кнопку Channals и выберите интересующие сигналы на линиях RB3, 
RE0, RE1; 

- установите переключатель Trigger Position на Start; 
- установите точки останова на команде call Dysplay и команде return 

подпрограммы Dysplay; 
- запустите выполнение программы командой Debugger>Run; 
- при первом останове программы, используя окно наблюдения, измените 

содержимое ячеек Fig2, Fig1, Fig0 на соответственно значения H’71’, H’A5’, 
H’5A’; 

- запустите программу; 
- при втором останове программы скопируйте в буфер обмена временные 

диаграммы из окна логического анализатора по команде Copy to Clipboard; 
- вставьте временные диаграммы из буфера обмена в отчет. 
6.2.3 Подключите отладчик MICD2 к стенду и персональному компьюте-

ру. Только после этого  можно подключить к отладчику MICD2 источник 
питания. Нарушение этого требования может привести к выходу из строя пор-
тов компьютера и отладчика MICD2! 

Активируйте отладчик MPLAB IDE для работы с MICD2 (команда 
Debugger>Select Tool>MPLAB ICD2). С помощью инструмента MPLAB ICD2 
Setup Wizard настройте отладчик MPLAB IDE для выполнения комплексной от-
ладки данного приложения. Установите связь с отладчиком MICD2 командой 
Debugger>Connect. Если в окне Output на закладке MPLAB ICD2 появится со-
общение об ошибке, проверьте подключение источника питания, разъемы и со-
единительные кабели.  

После установления связи, загрузки программного обеспечения отладчи-
ка (Operating System) и самотестирования выполните загрузку целевого прило-
жения в микроконтроллер отладочного стенда по команде Debugger>Program.  
 Активируйте выполнение программы в режиме реального времени. С по-
мощью потенциометра изменяйте значение входного напряжения и фиксируйте 
результат аналого-цифрового преобразования на 7-сегментных индикаторах. 
Проконтролируйте правильность отображения информации.  

Отключите отладчик системы MPLAB IDE командой Debugger>Select 
Tool>None. Отключите питание MICD2. После этого можно отключить 
кабель от COM-порта компьютера. Закройте проект командой Project>Close. 
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6.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- схему алгоритма программы; 
- исходный текст программы; 
- синтез управляющих слов; 
- временные диаграммы сигналов; 
- выводы. 
 
6.4 Контрольные  вопросы 
 
6.4.1 Поясните по схеме алгоритма работу программы. 
6.4.2 Каким образом выполняется вывод информации на 7-сегментные 

индикаторы отладочного стенда? 
6.4.3 Как можно проконтролировать корректность работы подпрограммы 

вывода на 7-сегментные индикаторы? 
6.4.4 Как выполняется настройка логического анализатора системы 

MPLAB IDE? 
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7 Отладка программы, использующей прерывания 
 
7.1 Описание работы с кратким изложением теории  
 
Цель работы - получить практические навыки выполнения автономной и 

комплексной отладки в среде MPLAB IDE программ, использующих механизм 
прерываний. Объектом отладки в работе является программа, использующая 
механизм прерываний. Основные функции программы: 

- отсчет времени и его отображение в секундах на 7-сегментных индика-
торах; 

- разнонаправленная модификация содержимого ячейки Cnt при нажатии 
с последующим отпусканием кнопок RB1 и RB2 и отображение ее содержимого 
на светоизлучающих диодах, подключенных к линиям порта PORTD.  

Прерывания возникают при переполнении таймера TMR0, анализ состоя-
ния линий RB1 и RB2 выполняется путем программного опроса в главном цик-
ле основной программы. 

 
7.2 Описание последовательности выполнения 

 
7.2.1 В своей рабочей папке создайте папку lr7. Скопируйте в нее подго-

товленный файл с исходным текстом программы lr7.asm. Создайте новый про-
ект с помощью мастера Project > Project Wizard. Задайте имя проекта lr7, вклю-
чите в проект исходный текст программы lr7.asm. 

Откройте окно с исходным текстом программы. Выполните трансляцию 
программы (команда Project>Make). Если программа содержала синтаксиче-
ские и другие формальные ошибки, исправьте их и повторите трансляцию.  

7.2.2 Проверку работы программы, поиск и исправление возможных 
ошибок выполняют в ходе отладки. Активируйте инструмент MPLAB-SIM 
Simulator командой Debugger> Select Tool>MPLAB SIM. Сформируйте удобную 
среду для отладки программы. 

Контролировать текущие значения данных можно в окне наблюдения. 
Создайте смотровое окно командой View> Watch. Включите в смотровое окно 
основные ячейки: 

- PORTB; 
- CntT (счетчик переполнений таймера); 
- Cnt (счетчик); 
- Fig0 (разряды 1-0 7-сегментного индикатора); 
- TMR0; 
- INTCON; 
- STATUS; 
- W_temp; 
- Status_temp.  
Для автономной отладки программы необходимо иметь средства имита-

ции нажатия кнопок RB1 и RB2. Для этих целей можно использовать асин-
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хронные стимулы. Cоздайте асинхронные стимулы RB1 и RB2 командами ме-
ню Debugger>Stimulus Controller> New Workbook.  

Контролировать сохранение точки возврата можно в окне стека. Откройте 
окно стека командой View>Hardware Stack. Для контроля формируемых интер-
валов времени откройте окно секундомера Debugger>Stopwatch. 

7.2.3 Целесообразно сначала выполнить проверку работы основной про-
граммы, а затем проконтролировать возникновение и обработку прерываний.  

Проверку работы основной программы удобно  выполнять в режиме ани-
мации (Debugger>Animate). Используя стимулы RB1 и RB2, проверьте кор-
ректность изменений содержимого ячейки Cnt.  

Чтобы проконтролировать возникновение и обработку прерываний в ре-
жиме анимации, потребуется слишком много времени. Более рационально ис-
пользовать режим прогона до точки останова. Установите точку останова на 
векторе прерывания. Запустите выполнение программы командой Debugger> 
Run. Убедитесь, что происходит передача управления на вектор прерывания. 
Зафиксируйте в отчете содержимое регистров TMR0, INTCON и стека. Выпол-
ните подпрограмму обработки прерывания в пошаговом режиме. Проконтроли-
руйте, как происходит сохранение и восстановление контекста. По показаниям 
секундомера определите интервалы времени между последовательными преры-
ваниями. Измените адрес точки останова так, чтобы можно было определить 
интервалы времени, через которые происходят изменения содержимого ячейки 
Fig0. Занесите результаты измерений в отчет. 

7.2.4 Подключите отладчик MICD2 к стенду и персональному компьюте-
ру. Только после этого  можно подключить к отладчику MICD2 источник 
питания. Нарушение этого требования может привести к выходу из строя пор-
тов компьютера и отладчика MICD2! 

Активируйте отладчик MPLAB IDE для работы с MICD2 (команда 
Debugger>Select Tool>MPLAB ICD2). С помощью инструмента MPLAB ICD2 
Setup Wizard настройте отладчик MPLAB IDE для выполнения комплексной от-
ладки данного приложения. Установите связь с отладчиком MICD2 командой 
Debugger>Connect. Если в окне Output на закладке MPLAB ICD2 появится со-
общение об ошибке, проверьте подключение источника питания, разъемы и со-
единительные кабели.  

После установления связи, загрузки программного обеспечения отладчи-
ка (Operating System) и самотестирования выполните загрузку целевого прило-
жения в микроконтроллер отладочного стенда по команде Debugger> Program.  
 Активируйте выполнение программы в режиме реального времени. На-
жатием кнопок RB1 и RB2 изменяйте состояния светодиодов. Убедитесь, что 
показания 7-сегментных индикаторов изменяются через одну секунду, незави-
симо от состояния кнопок RB1 и RB2.  

Отключите отладчик системы MPLAB IDE командой Debugger> Select 
Tool>None. Отключите питание MICD2. После этого можно отключить 
кабель от COM-порта компьютера. Закройте проект командой Project>Close. 
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7.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- схему алгоритма и исходный текст программы; 
- результаты тестирования программы; 
- выводы. 
 
7.4 Контрольные  вопросы 
 
7.4.1 Поясните по схеме алгоритма работу программы. 
7.4.2 Когда целесообразно использовать механизм прерываний? 
7.4.3 Как выполняется обработка запросов прерываний? 
7.4.4 Как можно выполнять автономную отладку программ, использующих 

механизм прерываний? 
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8 Отладка программной реализации микропрограммного     
автомата 

 
8.1 Описание работы с кратким изложением теории  
 
Цель работы - получить практические навыки выполнения автономной и 

комплексной отладки в среде MPLAB IDE программы, реализующей функцию 
микропрограммного управляющего автомата. 

Объектом отладки в работе является программа, которая: 
- опрашивает входные линии RE2  и RA5 МК, на которые поступает на-

бор входных сигналов X=<x2,x1>; 
- формирует на линиях 7-4 PORTD текущие значения набора выходных 

сигналов Y=<y4,y3, y2,y1>.  
Смена внутренних состояний автомата происходит при прерывании, ини-

циатором которого является положительный фронт внешнего сигнала Clk на 
линии INT/PB0. 

Перед выполнением тестирования программы, необходимо составить его 
план. Для автомата Мура, алгоритм которого задан ГСА и графом состояний 
(рисунок 8.1), предусмотрено выполнение переходов: 

- s0 – s1; s0 – s2; 
- s1 – s3; s1 – s5; 
- s2 – s3; s2 – s5; 
- s3 – s4; 
- s4 – s0; 
- s5 – s3; s5 – s5. 

 

 
Рисунок 8.1 

 
Необходимо сформировать такую цепочку из этих переходов, чтобы в ней 

были все переходы, а  их общее число было минимально, например: 
 

 s0 – s1 – s5 – s5 – s3 – s4 – s0 – s2 – s3 – s4 – s0 – s2 – s5.  
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Для данной последовательности сформируем тест, задавая последовательность 
соответствующих значений входных сигналов x1, x2, необходимых для выпол-
нения каждого перехода: 
 
x1  0 – 0 – 0 – 0 – 0 – 0 – 1 – 1 – 1 – 1 – 1 – 0 
x2  0 – 0 – 0 – 1 – 1 – 1 – 1 – 1 – 1 – 1 – 0 – 0 
 
 Каждый набор входных сигналов должен сопровождаться синхроимпуль-
сом Clk. 

 
8.2 Описание последовательности выполнения 

 
8.2.1 В своей рабочей папке создайте папку lr8. Скопируйте в нее подго-

товленный файл с исходным текстом программы lr8.asm. Создайте новый про-
ект с помощью мастера Project > Project Wizard. Задайте имя проекта lr8, вклю-
чите в проект исходный текст программы lr8.asm. 

Откройте окно с исходным текстом программы. Автономную отладку 
программы целесообразно выполнять с отключенной функцией подавления 
дребезга контактов. Выполните трансляцию программы (команда Project> 
Make). Если программа содержала синтаксические и другие формальные ошиб-
ки, исправьте их и повторите трансляцию.  

8.2.2 Проверку работы программы, поиск и исправление возможных 
ошибок выполняют в ходе отладки. Активируйте инструмент MPLAB-SIM 
Simulator командой Debugger> Select Tool>MPLAB SIM. Сформируйте удобную 
среду для отладки программы. Для отладки программы необходимо иметь 
средства имитации источников входных сигналов X=<x1,x2> и сигнала Clk. Для 
этих целей можно использовать стимулы. Также необходимы инструменты для 
отслеживания выполнения программы. 

Автономную отладку данной программы можно выполнить в режиме 
анимации или режиме автоматического прогона программы. В первом случае 
потребуются асинхронные стимулы для сигналов на линиях RE2, RA5 и RB0. 
Контролировать текущие значения данных можно в окне наблюдения, в кото-
ром должны отражаться ячейки: PORTA, PORTB, PORTD, PORTE, InWord, 
OutWord. Методика отладки программ в этом режиме подробно рассмотрена на 
лабораторном занятии №4. 

Проще и быстрее автономную отладку данной программы выполнить в 
режиме автоматического прогона при фиксации основных ячеек в буфере трас-
сы и отображении входных и выходных сигналов управляющего автомата в ок-
не логического анализатора. В данном случае потребуется использовать син-
хронные стимулы.  

Создайте стимулы RE2, RA5 и RB0 командами меню Debugger>Stimulus 
Controller>New Workbook. В окне Stimulus выберите закладку Clock Stimulus, на 
которой задайте параметры стимула тактового сигнала Clk с периодом повто-
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рения 100 машинных циклов на линии RB0. Соответствующие значения пара-
метров приведены в таблице 8.1.   

 
Таблица 8.1 

Label Pin Initial Low Cyc High Cyc Begin End 
Clk RB0 Low 50 50 At Start Never 

 
 Для рассматриваемого примера, при условии следования входных набо-
ров с интервалом 100 циклов, соответствующие изменения сигнала x1 на линии 
PA5 должны происходить на отметках времени 6*100 = 600 циклов и (6+5)*100 
=1100 циклов. Изменения сигнала x2 на линии PE2 должны происходить на от-
метках времени 3*100 = 300 циклов и (3+7)*100 = 1000 циклов. 

На закладке Pin/Register Actions нажмите на заголовок столбца таблицы 
Click here to Add Signals. В открывшемся окне последовательно выберите нуж-
ные сигнальные линии и добавьте их в список Secected Signals нажатием кноп-
ки Add. Подтвердите выбор нажатием кнопки OK. В ячейках сформированной 
таблицы задайте параметры стимулов сигналов x1, x2 , действующих на линиях 
RE2  и RA5. Для рассматриваемого примера образец таблицы приведен на ри-
сунке 8.2. Нажатием кнопки Apply подтвердите подключение созданных сти-
мулов к программно-логической модели. Сохраните стимулы в файле (кнопка 
Save).  

 
 

 

Рисунок 8.2 
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8.2.3 Выполните тестирование программы, используя подготовленные 
стимулы. В соответствии с планом тестирования необходимо выполнять про-
грамму на протяжении следования 12 наборов входных сигналов. Это значит, 
что на протяжении интервала выполнения программы должно произойти 12 
прерываний программы по фронту сигнала Clk. Прекратить выполнение про-
граммы можно на 13-м по счету прерывании. Наиболее просто это обеспечить, 
используя сложные условия останова отладчика системы MPLAB IDE. Выпол-
ните команду Debugger>Complex Breakpoints. В открывшемся окне Simulator 
Complex Breakpoints нажмите кнопку Add Breakpoint. В окне Set Breakpoint на 
закладке Program Memory  необходимо в окне Address задать метку точки оста-
нова – вход в подпрограмму обработки прерывания. В окне Pass Count выбери-
те условие Event must occur Count times,  в окне Count задайте число событий 
(прерываний) до останова программы. 

Откройте окно логического анализатора командой View>Logic Analyzer, 
нажмите кнопку Channals и выберите сигналы на линиях RE2, RA5, RB0, RD4, 
RD5, RD6, RD7. Установить переключатель Trigger Position на Start. 

Запустите выполнение программы в автоматическом режиме. После ос-
танова программы, используя окно логического анализатора, исследуйте вре-
менные диаграммы зарегистрированных сигналов. 

Убедитесь, что: 
- происходит смена значений выходных сигналов на линиях RD4, RD5, 

RD6, RD7 после формирования положительного фронта тактового сигнала ав-
томата на линии RB0;  

- смена формируемых выходных наборов соответствует заданному алго-
ритму функционирования автомата.  

Зарегистрированные временные диаграммы для рассматриваемого при-
мера приведены на рисунке 8.3. 

 

 

Рисунок 8.3 
 

При успешном прохождении теста скопируйте временные диаграммы из 
окна логического анализатора в буфер обмена по команде Copy to Clipboard. 
Вставьте временные диаграммы из буфера обмена в отчет. 
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В случае, если значения выходных сигналов не изменяются, необходимо 
проверить настройку системы прерываний МК и корректность работы подпро-
граммы обработки прерываний по рекомендациям, рассмотренным на лабора-
торном занятии №7. Если характер изменений значений выходных сигналов 
отличается от правильных, то причина этого, скорее всего, в ошибках, допу-
щенных при формировании табличного представления функций переходов-
выходов автомата. После локализации и исправления ошибок, необходимо по-
вторить трансляцию и тестирование исправленного варианта программы.  

8.2.4 Перед выполнением комплексной отладки программы необходимо 
подключить функцию подавления дребезга контактов кнопки и повторно вы-
полнить трансляцию программы. 

Подключите отладчик MICD2 к стенду и персональному компьютеру. 
Только после этого  можно подключить к отладчику MICD2 источник 
питания. Нарушение этого требования может привести к выходу из строя 
портов компьютера и отладчика MICD2! 

Активируйте отладчик MPLAB IDE для работы с MICD2 (команда 
Debugger>Select Tool>MPLAB ICD2). С помощью инструмента MPLAB ICD2 
Setup Wizard настройте отладчик MPLAB IDE для выполнения комплексной 
отладки данного приложения. Установите связь с отладчиком MICD2 коман-
дой Debugger>Connect. Если в окне Output на закладке MPLAB ICD2 появится 
сообщение об ошибке, проверьте подключение источника питания, разъемы и 
соединительные кабели.  

После установления связи, загрузки программного обеспечения отладчи-
ка (Operating System) и самотестирования выполните загрузку целевого прило-
жения в микроконтроллер отладочного стенда по команде Debugger> Program.  
 Активируйте выполнение программы в режиме реального времени. Уста-
навливая DIP-переключателями необходимые комбинации входных сигналов 
X=<x1,x2> и нажатием кнопки RB0 имитируя формирование фронта сигнала 
Clk, проконтролируйте по состоянию светодиодов значения выходных сигна-
лов и кода состояния. Убедитесь, что работа программной реализации управ-
ляющего микропрограммного автомата соответствует заданному алгоритму.  

Отключите отладчик системы MPLAB IDE командой Debugger> Select 
Tool>None. Отключите питание MICD2. После этого можно отключить 
кабель от COM-порта компьютера. Закройте проект командой Project>Close. 

 
8.3 Оформление работы 
 
Отчет по лабораторной работе должен содержать: 
- граф состояний автомата; 
- схему алгоритма и исходный текст программы; 
- результаты тестирования программы (временные диаграммы); 
- выводы. 
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8.4 Контрольные  вопросы 
 
8.4.1 Поясните по схеме алгоритма работу программы. 
8.4.2 Как можно сформировать входной тест для проверки микропрограмм-

ного автомата? 
8.4.3 Как можно выполнять автономную отладку программной реализации 

управляющего микропрограммного автомата? 
8.4.4 Как можно выполнять комплексную отладку программной реализации 

управляющего микропрограммного автомата? 
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